Closed Bug 1625827 Opened 4 years ago Closed 4 years ago

pointerdown event fired twice in "Responsive Design Mode"

Categories

(DevTools :: Responsive Design Mode, defect, P3)

74 Branch
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1516805

People

(Reporter: dpapad, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

  1. Visit https://jsfiddle.net/832zoud5/1/
  2. Open DevTools and click on "Responsive Design Mode"
  3. Make sure that "touch simulation" is enabled (see icon next to the "throttling" dropdown)
  4. Click once on the "Click me" div and obserne console output.

Actual results:

Two pointerdown events are fired, with a small delay in between.

Expected results:

Only one pointerdown event should be fired.

Component: DOM: Events → Responsive Design Mode
Product: Core → DevTools

Thanks for filing. We have a number of bugs in our touch simulation that we hope to address soon.

Blocks: rdm-touch
Priority: -- → P3

The pointerType of the first pointerdown event is is "mouse" and the second one's pointerType is "touch".

It looks like this problem could be resolved by Bug 1516805 when it's addressed. I'll mark that as a "See Also".

Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → 1516805
See Also: → 1608708

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is P3 (Backlog,) indicating it has been triaged, the bug's Severity is being updated to S3 (normal.)

Severity: normal → S3

Resolving this as a duplicate of Bug 1516805 now that RDM doesn't dispatch mouse pointerevents when touch is enabled.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.