Does not refresh after opening minimized window

VERIFIED DUPLICATE of bug 2421

Status

Core Graveyard
Viewer App
P1
major
VERIFIED DUPLICATE of bug 2421
19 years ago
9 years ago

People

(Reporter: Claudius Gayle, Assigned: michaelp)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
XPViewer on WinNT and Win95:
 The browser does not redraw the interior of the window when you open a
once-minimized window.
To reproduce:
1. Launch XPViewer.exe.
2. Confirm that the window is in a 'tiled' state, i.e. not maximized by pressing
maximize button.
3. Minimize.
4. Un-minimize

You would expect that the page was re-layed out but you'd be wrong. It acts like
a transparent window (I know that's an oxymoron) because you can see the desktop
through it.

Updated

19 years ago
Assignee: kipp → michaelp

Updated

19 years ago
Summary: ss:does not refresh after opening minimized window → rn:does not refresh after opening minimized window

Comment 1

19 years ago
Taking off ss: list per bug mtg today.  Putting on Release Notes.
(Assignee)

Updated

19 years ago
Assignee: michaelp → rickg
Component: Layout → Viewer App
(Assignee)

Comment 2

19 years ago
this is because there is no document to draw because the URL is bad. the fix
for this is for some other level of the app to detect the case of a bad url and
create and empty document so that we at least paint the window white or
something.

Updated

19 years ago
Assignee: rickg → jevering

Comment 3

19 years ago
I'm unable to reproduce this. Perhaps you can verify and then close it out.
(Reporter)

Updated

19 years ago
(Reporter)

Comment 4

19 years ago
I just looked at this again and I don't think it's because of a bad url. I just
reproduced it at majorleaguebaseball.com. The behavior is similar to what was
noted before. In this case it only draws the MLB logo. I believe this problem
has something to do with the way the browser handles frames - just a hunch but I
just noticed I haven't seen this on a non-frames site.

Updated

19 years ago
Summary: rn:does not refresh after opening minimized window → Does not refresh after opening minimized window

Comment 5

19 years ago
This now in Release Notes.  Taking off rn: radar.

Updated

19 years ago
Assignee: jevering → michaelp

Comment 6

19 years ago
This bug still exists. The 'main' frame doesn't show any text. Jevering is
obviously not the right person for it, re-assigning to michaelp (guessing).
Please reassign if you're not the right guy.
(Reporter)

Comment 7

19 years ago
installing myself as QA Contact for sevaral bugs at once

Comment 8

19 years ago
Is this bug on Win32 only?  also, this was reported against xpViewer which is no
longer valid.  claudius, please try all 3 platforms with Feb01 build and give us
the scoop.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 9

19 years ago
*** This bug has been marked as a duplicate of 2421 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

19 years ago
marking verified as duplicate of 2421. Logic dictates that 2421 be marke a duplicate of 1626, but whatever.
My new comments will appear on that bug.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.