Closed Bug 1626071 Opened 3 years ago Closed 1 year ago

'about:reader?url=' location does not work for 'file:' urls - why ?

Categories

(Toolkit :: Reader Mode, enhancement)

74 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1166829

People

(Reporter: jason.vas.dias, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

Type 'about:reader?url='${my url...} to load a local filesystem html file in Reader View mode.
Eg. I have a file '/tmp/t.html' so I type into the location bar :
'about:reader?url=file%3A%2F%2Ftmp%2Ft.html
.

Actual results:

A blank page is displayed.

Expected results:

The /tmp/t.html file should have been displayed in Reader View mode.

When I replace 'file:' with 'http:' or 'https:' in an URL which serves a copy of the same file , the
file is displayed in Reader View mode - why doesn't it work for 'file:' URLs ?
Please could Mozilla in future display 'file:' URLs in Reader View ?
These are files for which the Reader View icon is not displayed automatically in the location bar.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Reader Mode
Product: Firefox → Toolkit

I fixed this in bug 1166829 for Firefox 86.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1166829
You need to log in before you can comment on or make changes to this bug.