Open Bug 1626132 Opened 2 months ago Updated 15 days ago

Ghost-Windows from reddit

Categories

(Core :: Performance, defect)

defect

Tracking

()

People

(Reporter: tcampbell, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qf:p2:responsiveness])

Basic information

Steps to Reproduce:
Visit a Slack instance migrated to new design (so not the Mozilla one).
Idle and type in message box.

Expected Results:
Smooth typing

Actual Results:
3 second pauses


More information

Screenshot: (if relevant, please attach a screenshot or screencast to this bug report)

Profile URL: https://bit.ly/2ylSnPn

Basic systems configuration:

OS version: Windows 10

GPU model: Intel

Number of cores: 4/8

Amount of memory (RAM): 16 GB

Thanks so much for your help.

You'll also want an about:memory report. Maybe a CC log, too, because that records what the CC is actually looking at. Skimming the profile, it looks like most of the time is being spent traversing JS.

(The CC log will contain lots of data in memory, so you may not want to share it publicly.)

Whiteboard: [wfh] → [wfh][qf:p2:responsiveness]

Looking at my about:memory, I have a number of very large ghost windows in that content process.

Ok. That means we're leaking windows, which causes the cycle collector to be very slow. Somebody who can reproduce it will have to debug the memory leak.

For how long did you idle to see this out of curiosity?

Also, I think there's a slack instance with the new design everyone can join in https://w3ccommunity.slack.com/.

Restarting did fix things. I tried to capture a GC/CC log and it actually hung in the parent process while infinitely trying to trace. I couldn't get WinDBG to behave. I have the partial CC/GC logs which I can try getting into.

This session was probably a week old. The ghost windows were mostly reddit.

Do you have any Reddit-related extensions installed? Do you use the old or new layout for Reddit? I use Reddit a fair amount, but I haven't noticed any big slowdown, but with Fission processes get created and killed more frequently.

No extensions except Containers and Profiler. Was on new-reddit. I've not run into this before and this session wasn't really different than what I normally do. I guess running nightly for more than 48hr is unusual for me though.

Actually, that is incorrect. BuildID from profile says this was only running for a day when it happened. I'll keep an eye on if I see ghost windows again.

This doesn't seem to be a slack issue, but rather the content process had ghost-windows in it. As a result, I'm renaming this bug and clearing [wfh].

Perhaps this should be closed as WORKSFORME. I'm not sure how we deal with unreproducible ghost-windows.

Summary: Large CycleCollector pause on new Slack UI → Ghost-Windows from reddit
Whiteboard: [wfh][qf:p2:responsiveness] → [qf:p2:responsiveness]

If this happens again, please get GC/CC logs using about:memory. Then you can run find_roots.py and maybe get some information on what is keeping the Reddit windows alive.

Bug 1628664 is another bug about ghost windows on Reddit.

See Also: → 1628664

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Severity: normal → --
You need to log in before you can comment on or make changes to this bug.