Closed Bug 1626155 Opened 7 months ago Closed 7 months ago

nsLayoutUtils::TransformAncestorPointToFrame passes null for ancestor frame

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox-esr68 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Regressed by: svgtext

It probably doesn't case any problems because the two callers of the function don't hit the case with the bug.

nsLayoutUtils::TransformRootPointToFrame passes nullptr for the ancester frame.

nsIFrame::GetContentOffsetsFromPoint only calls this function if aFrame is in an svg text subtree, so it takes the other branch.

Looks like this was a simple oversight in this change

https://hg.mozilla.org/mozilla-central/rev/204b51a6c6458a30be158a3d1bdca8e9b4edfd67

where TransformRootPointToFrame was changed to TransformAncestorPointToFrame and it originally passed nullptr (which was correct to the Root version fo the function) but didn't get updated in the change.

Assignee: nobody → tnikkel
Status: NEW → ASSIGNED
Attachment #9137032 - Attachment description: Bug 1626155. nsLayoutUtils::TransformAncestorPointToFrame passes null for ancestor frame. r?botond → Bug 1626155. nsLayoutUtils::TransformAncestorPointToFrame passes null for ancestor frame. r=botond
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3506ad8b3ae2
nsLayoutUtils::TransformAncestorPointToFrame passes null for ancestor frame. r=botond
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
You need to log in before you can comment on or make changes to this bug.