Closed Bug 1626195 Opened 4 months ago Closed 4 months ago

Cogwheel for Protection level not vertically centered in div

Categories

(Firefox :: Protections UI, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 77
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- wontfix
firefox76 --- verified
firefox77 --- verified

People

(Reporter: cfogel, Assigned: aarushivij)

Details

(Keywords: good-first-bug, regression)

Attachments

(2 files)

Affected versions

  • 75.0b11, 76.0a1 (2020-03-30)

Affected platforms

  • macOS 10.15, Windows 10, Ubuntu 18.04;

Steps to reproduce

  1. Launch Firefox, access about:protections
  2. Hover over the cogwheel for the protections level

Expected result

  • elements are properly displayed;

Actual result

  • top padding doesn't match bottom padding for the icon;

Regression range

  • will check if one and provide confirmation asap;

Additional notes

  • attached screenshot with the issue.
Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression
Keywords: good-first-bug
Priority: -- → P2

Hello, Can I take up this issue?
Thanks :)
Aarushi

Flags: needinfo?(ewright)

(In reply to aarushivij from comment #3)

Hello, Can I take up this issue?
Thanks :)
Aarushi

Hi Aarushi, go for it, and thank you!

Flags: needinfo?(ewright)
Assignee: nobody → aarushivij
Status: NEW → ASSIGNED
Pushed by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9017241c45e6
Cogwheel for Protection level not vertically centered in div r=ewright
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77

Comment on attachment 9139386 [details]
Bug 1626195 - Cogwheel for Protection level not vertically centered in div r=ewright

Beta/Release Uplift Approval Request

  • User impact if declined: Protection Report does not appear polished, since styling of cogwheel is 3 px off center.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): one line CSS only change.
  • String changes made/needed: none
Attachment #9139386 - Flags: approval-mozilla-beta?

Comment on attachment 9139386 [details]
Bug 1626195 - Cogwheel for Protection level not vertically centered in div r=ewright

Trivial one-liner CSS fix for a visual glitch. Approved for 76.0b5.

Flags: needinfo?(itiel_yn8)
Attachment #9139386 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Awesome. Verified with 76.0b5, 77.0a1 (2020-04-15) on the mentioned platforms.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.