Closed Bug 1626282 Opened 11 months ago Closed 1 month ago

WarpBuilder: pass jit-tests

Categories

(Core :: JavaScript Engine: JIT, task, P1)

task

Tracking

()

RESOLVED FIXED

People

(Reporter: jandem, Assigned: jandem)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

There are about 30 test failures with --ion-eager --warp --no-threads. Most of these are caused by error messages and debugger sometimes behaving differently for Ion frames - typically not a problem for IonBuilder because it will bail out to Baseline for empty TypeSets with --ion-eager but WarpBuilder is more resilient to that.

Priority: -- → P1
Summary: WarBuilder: pass jit-tests → WarpBuilder: pass jit-tests
Depends on: 1626294
Depends on: 1626606
Depends on: 1626615
Depends on: 1626852
Depends on: 1626859
Depends on: 1626893
Blocks: 1627174
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.