Closed Bug 1626378 Opened 8 months ago Closed 8 months ago

Category tabs do not get role="tab"

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected
firefox76 + fixed

People

(Reporter: Jamie, Assigned: mstriemer)

References

(Regression)

Details

(Keywords: access, regression, Whiteboard: [access-p1])

Attachments

(1 file)

In the new HTMl side bar, the category buttons are missing role="tab". They do get a parent role="tablist" and they do get aria-selected="true" when selected. Unfortunately, aria-selected is currently ignored because the role is wrong.

The tabs for individual add-ons still get role="tab" as they should.

Hmm, I could've swore they had one, although I do remember refactoring that at one point and may have forgotten about these buttons. I'll add that back in.

Assignee: nobody → mstriemer
Priority: -- → P1
Blocks: 1624538
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3d2fd118323b
Set role="tab" on about:addons categories r=rpl
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
You need to log in before you can comment on or make changes to this bug.