No bookmarks no back button

RESOLVED DUPLICATE of bug 160980

Status

SeaMonkey
UI Design
--
major
RESOLVED DUPLICATE of bug 160980
16 years ago
14 years ago

People

(Reporter: Arne Falk, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1b) Gecko/20020813
BuildID:    2002081308

This version, and the one from yesterday does not show my bookmarks, and the
back button does not work.

Reproducible: Always
Steps to Reproduce:
1. goto any url
2. klick on a link
3. klick on back button

Actual Results:  nothing, and no bookmarks

Expected Results:  former page, and bookmarks

Comment 1

16 years ago
Did you install this build over an older build?

You shouldn't do that..

Try to create a new profile for this build (using the profilemanager) and / or
remove mozilla and reinstall it again.

(Make sure to backup your Mail and other important personal stuff if you delete
a profile)

thanks

Comment 2

16 years ago
I had the same problem yesterday when I uninstalled and old build (1.1 a) and
installed a new nightly build.

It did not help to make a new profile, so remove the install folder (C:\Program
Files\mozilla.org\) and reinstall and it should work.

Comment 3

16 years ago
*** Bug 162649 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

16 years ago
Yes I did only update on older version, so that is the problem.

Will it be upgradeable in the future ?

Comment 5

16 years ago
Try to open up the window explorer and find the mozilla directory.  Then make a
backup copy of all of the file under the folder "mozilla.org" to the desktop. 
This can be done with copy and paste.  Then delete all of those files in the
mozilla.org directory expect the folder, "plugin".  Try that and see if that
help with your problem.
(Reporter)

Comment 6

16 years ago
To comment #5, your suggestion helped.

Comment 7

16 years ago
Yeah, comment 5 is the solution
Too bad i removed all my plugins... :-(

Comment 8

16 years ago
Oh no!  The plugin was removed.  :-)  It shouldn't be too hard to take it out of
the recycle bin.  Or copy the plugin directory over from the backup where the
plugin is found if you made the backup.

I read the Moz startup page when I installed the Moz, it commented that the
effective way to do the upgrade is to make a backup copy of the Mozilla.org
directory to a safe place.  Then delete all of the stuffs inside the mozilla.org
folder except the plugin.  So, I followed that suggestion and haven't have had
that much problem.  :-)

Since you said yours work, so you would need to update the bug to "Resovled as
Fix".  I don't have the authority for that.
(Reporter)

Comment 9

16 years ago
Is it really fixed ?

Should'nt it be upgradeable ? 
You might have to live with theese things in a daily build, but when it gets
into a release I dont think it is acceptable ?

I suspect this has to do with the fixing of bug 12911

Comment 10

16 years ago
My understanding is that Mozilla is only a development browser.  I have no idea
what does Netscape, Konqueror and other browsers do with this Mozilla packages.
 Maybe you can write a special installer to make this upgrade to work well?  :-)
 But your point is well taken and I'll accept that.

Comment 11

16 years ago
If you used the standard 'wizard-style' installer to upgrade Mozilla, the
installer should have prompted you to delete the old version first. Was this not
the case?
(Reporter)

Comment 12

16 years ago
No I was not prompted to remove old version. I use to upgrade mozilla once a
week, and this is the first time I have had any problem at all.

I Do believe the problem has to do with the fixing of bug 12911, the night
before. The bug was about rewriting paths to among other things bookmarks. 

Comment 13

16 years ago

*** This bug has been marked as a duplicate of 160980 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.