Closed Bug 1626424 Opened 2 years ago Closed 7 months ago

add ftp to permitted protocol handlers

Categories

(WebExtensions :: General, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1626365

People

(Reporter: mixedpuppy, Unassigned, Mentored)

Details

(Keywords: good-first-bug)

Once ftp is removed, we could add it to the protocol handlers. This could potentially allow an addon to mitigate the loss of native ftp support.

https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/manifest.json/protocol_handlers

Philipp, what do you think about this?

We're thinking of adding ftp to this now, but ignoring it until a version of firefox that has removed the ability to turn on ftp.

Flags: needinfo?(philipp)
Priority: -- → P3

Redirecting product question in comment 1 from Philipp to Jorge.

Flags: needinfo?(philipp) → needinfo?(jorge)

Sounds good to me.

Flags: needinfo?(jorge)

Marking this as a good-first-bug. To get started, see https://wiki.mozilla.org/WebExtensions/Contribution_Onramp

As a first step, we should support protocol_handlers in the schema: https://searchfox.org/mozilla-central/rev/9c72508fcf2bba709a5b5b9eae9da35e0c707baa/toolkit/components/extensions/schemas/extension_protocol_handlers.json#14-23

If the network.ftp.enabled pref is false, then the implementation should allow extensions to register the extension. Otherwise the protocol should be ignored. The implementation of the protocol_handlers API is at https://searchfox.org/mozilla-central/source/toolkit/components/extensions/parent/ext-protocolHandlers.js

The patch should also include a unit test to verify that the change works as expected. Search for protocol_handlers in Searchfox to find existing examples.

Mentor: rob
Keywords: good-first-bug

Hello, can I work this issue for my Outreachy application?

(In reply to xu from comment #5)

Hello, can I work this issue for my Outreachy application?

Yes. We have already chatted on Matrix. The bug will automatically be assigned to you once you attach a patch.

Sorry, given that we needed this right now I took it.

No longer blocks: 1626365
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1626365
You need to log in before you can comment on or make changes to this bug.