nested subfolders are not all shown, only two levels

VERIFIED DUPLICATE of bug 147528

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 147528
16 years ago
2 years ago

People

(Reporter: Henry Jia, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
If you deselect 'Show only subscribed folders' in 'Advanced IMAP Server
Settings', mozilla will only show two level nested subfolders. Something like below.
subfolder 1
     |
      -- subfolder 2
         |
          -- subfolder 3-1
         |
          -- subfolder 3-2
subfolder 3-1 and 3-2 do not appear.

If the imap server support namespace, such as 'INBOX.', then the folders will be
as follows.
inbox 
 |
  -- subfolder 1
     |
      -- subfolder 2
         |
          -- subfolder 3-1
         |
          -- subfolder 3-2
subfolder 3-1 and 3-2 do not appear.
(Reporter)

Comment 1

16 years ago
From the code in nsImapProtocol::DiscoverMailboxList as follows, it seems not in
right behavior. But this is specially handled. Not sure why.

        if (usingSubscription)
        {
          pattern.Append(prefix);
          pattern.Append("*");
        }
        else
        {
          pattern.Append(prefix);
          pattern.Append("%"); // mscott just need one percent right?
          // pattern = PR_smprintf("%s%%", prefix);
          char delimiter = ns->GetDelimiter();
          if (delimiter)
          {
            // delimiter might be NIL, in which case there's no hierarchy anyway
            pattern2 = prefix;
            pattern2 += "%";
            pattern2 += delimiter;
            pattern2 += "%";
            // pattern2 = PR_smprintf("%s%%%c%%", prefix, delimiter);
          }
        }


        if (usingSubscription) // && !GetSubscribingNow())  should never get
here from subscribe pane
          Lsub(pattern.get(), PR_TRUE);
        else
        {
          List(pattern.get(), PR_TRUE);
          List(pattern2.get(), PR_TRUE);
        }

Add mscott to CC list.
(Reporter)

Comment 2

16 years ago
Created attachment 95236 [details] [diff] [review]
patch for review


please r=/sr=
(Reporter)

Updated

16 years ago
Keywords: nsbeta1, review

Comment 3

15 years ago
I've noticed this bug too - thanks to Henry though for mentioning the work
around (enabling Show only subscribed folders). If necessary I can provide an
IMAP protocol log, but looking at the code, it seems Henry has already
identified where the problem lies!

There's been a patch attached to this that's now nearly 5 months old; is this
the wrong patch, or has it just gotten lost in all the other work that has to be
done? Cheers :)
(Assignee)

Comment 4

15 years ago
Comment on attachment 95236 [details] [diff] [review]
patch for review

this will list all the folders in the user's directory, which could be quite
slow. The way this should work is we list sub-folders when we expand the parent
folder
Attachment #95236 - Flags: needs-work+

Comment 5

15 years ago
When we expand the parent folder,mozilla will list two levels of subfolders (of
this bug's condition) now. The error is we can't see if the second level of
subfolders is an-end-folder or still has its subfolders(ie.we can't see the +
ahead the folder icon).
(Reporter)

Comment 6

15 years ago
You can list the sub-folders when you select some folder. But we need to find a
way with high performance. Since listing the sub-folders whenever you select
some folder is also a low performance implementation. One proposal method is to
add a flag to the folder to indicate if its sub-folders listed.

Updated

15 years ago
QA Contact: olgam → laurel
(Assignee)

Comment 7

15 years ago
this is fixed (though you have to delete your .msf files to see the fix). I
changed it so that newly discovered folders are collapsed, so that when you
expand them, we list sub-folders. 
Assignee: sspitzer → bienvenu

Comment 8

15 years ago
marking this bug as dupe of bug 147528.

I verifed that bug.



*** This bug has been marked as a duplicate of 147528 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 9

15 years ago
marking verified
Status: RESOLVED → VERIFIED

Comment 10

15 years ago
I'm still seeing nested folder problems on the trunk.  See my comments in bug
147528.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.