Closed Bug 1626779 Opened 4 months ago Closed 4 months ago

Wizard page titles are missing in e.g. migration wizard after the changes from bug 1608197

Categories

(Firefox :: Migration, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected
firefox76 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

This is because if the wizard includes fluent and trips document.l10n creation, we end up trying to use fluent for the headers. If there's no fluent attribute on the wizardpage, we clear the label - but we shouldn't be doing that if there was never a fluent ID on there in the first place. We probably also shouldn't early-return after calling _adjustFluentHeaders.

Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/51ec9f7a372a
fix wizard page header handling so it copes with non-fluent labels, r=mconley
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76

Verified fixed as part of PI 551; tested with Nightly 77 across platforms (Windows 10, macOS 10.15 and Ubuntu 18.04).

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.