Closed Bug 1626944 Opened 4 years ago Closed 3 years ago

AutoComplete fails with LDAP and accented characters

Categories

(Thunderbird :: Message Compose Window, defect)

defect

Tracking

(thunderbird_esr78 wontfix, thunderbird90 affected)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- wontfix
thunderbird90 --- affected

People

(Reporter: algopirin2005ftw, Assigned: rnons)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

Using LDAP addressbook (and local ones as well).
There are names in it (mostly german), with (not-so-)special characters, such as "ö" and "ü" and so on.
Example A: "Jörg Börg", or another example B: "Jörg Borg".

Actual results:

When searching for any name in the LDAP Addressbook, it returns the expected results, regardless of special characters.

When composing a mail and using AutoComplete for address A, following happens:

  • start typing "Bör...": it only gives suggestions from the local addressbook, but not from LDAP
  • start typing "Jör...": same thing, no results from the LDAP, only from local adressbooks.
    When trying the same with address B:
  • Autocomplete works and gives suggestions from the LDAP source as well, as it should.

When I type this isntead: "*Bör..." it finds the names from LDAP, but then it is giving suggestions from LDAP only.

This seems to happen all the time, when the second part of CommonName contains such a special accented character.

Expected results:

AutoComplete should suggest the adresses from LDAP the same way as the Addressbook search does.

Sorry for being vague, I don't know much about this.

Component: Untriaged → Message Compose Window

What version were you using?
Do you still see this when using a newer version?

Flags: needinfo?(bsh)
Whiteboard: [closeme 2020-09-21]

This is a very long standing bug. I have it since years, just not reported until I started using LDAP heavily.
Currently used version is 68.12.0 and it seems to work now?! Wow. So does 68.11.0.

Flags: needinfo?(bsh)

Thanks for the update
Hopefully that continues in version 78

Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2020-09-21]

(In reply to Wayne Mery (:wsmwk) from comment #4)

Thanks for the update
Hopefully that continues in version 78

I have to report that I did find cases where it still doesn't work. Plus, it seems like middle names aren't parsed at all in compose.

Not working in 78.3.3

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

I am not finding any matching reports https://mzl.la/39S4uo8

Version: unspecified → 68

There's always a first... What evidence do you need?

Attached image Screenshot of the bug

Here's a screenshot. on the left is the TB Addressbook, the test ldap server is selected. On the top, started typing in "Jürgen" and it finds two matches on "Jür".
Doing the same in compose window (on the right), only finds one match (apart from the other matches taht come from local adressbooks). Doesn't find "Hans-Jürgen" that way.
This is just an example. It does not have to be such a name. Another one: Name is "Uxyz Özcan". Typing in "Öz" finds it in Addressbook, but not in compose window.

(In reply to Wayne Mery (:wsmwk) from comment #10)

Can you create a new profile https://support.mozilla.org/en-US/kb/using-multiple-profiles to see if this reproduces with beta https://archive.mozilla.org/pub/thunderbird/releases/90.0b2/ ?

beta implements new ldap code https://www-stage.thunderbird.net/en-US/thunderbird/90.0beta/releasenotes/

Tested it on a Win10 VM that never had Thunderbird installed before. Used the 64bit version of TB.
Unfortunatelly it behaves the same way as the current release.

Flags: needinfo?(bsh)

(silly question) rnons, which component are we using for ldap?

Flags: needinfo?(remotenonsense)

And can you reproduce this?

The template string was overcomplicated, and only supported matching from beginning. This patch simplifies it to support matching substrings.

Assignee: nobody → remotenonsense

The problem is not accented characters, but the filter string only matches the beginning of name/email. My patch changes to match any substring.

(In reply to Wayne Mery (:wsmwk) from comment #12)

which component are we using for ldap?

The current component looks good to me.

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(remotenonsense)
Target Milestone: --- → 91 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/d6a72e15b084
Change LDAP autocomplete template to match substrings. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → FIXED

Seems to work in 91b1

Regressions: 1726350
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: