Closed Bug 1627164 Opened 6 months ago Closed 3 months ago

lockwise edit/delete button line break

Categories

(Firefox :: about:logins, defect, P2)

74 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 79
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox79 --- verified

People

(Reporter: i, Assigned: kenrick95)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

  1. Go to about:logins
  2. Select a website with very long host name
  3. Check the buttons in the heading

Actual results:

Texts in buttons are breaking into lines

Expected results:

Texts in buttons should not break into lines

You can fix it by simply apply:

// login-item.css
.delete-button, .edit-button {
flex: 0 0 auto;
}

Component: Untriaged → about:logins
OS: Unspecified → All
Hardware: Unspecified → All
Status: UNCONFIRMED → NEW
Ever confirmed: true
Type: enhancement → defect
Priority: -- → P2

This only happens in specific locales (e.g. Japanese) since in such language, line break could happen in each letters. The fix here is to explicitly specify flex property so that the button couldn't shrink further.

Assignee: nobody → kenrick95
Status: NEW → ASSIGNED
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/df828f4d4697
Fix edit/delete buttons in about:logins break into lines r=MattN
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

I have verified this issue using the latest Firefox Nightly 79.0a1 ja build (Build ID: 20200628212804) on Windows 10 x64, Ubuntu 18.04, Mac 10.14.6.

  • The strings from the “Remove” and the “Edit” buttons don't break into lines anymore.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.