Closed Bug 1627179 Opened 4 months ago Closed 4 months ago

A promise chain failed to handle a rejection: A mutation operation was attempted on a database that did not allow mutations. - stack: ensureShutdownBlocker/<@resource://services-settings/Database.jsm:509:21

Categories

(Firefox :: Remote Settings Client, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected
firefox76 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

It seems if you call abort() and the transaction fails, we get an InvalidStateError with a confusing message (A mutation operation was attempted on a database that did not allow mutations. -- confusing because we're aborting readonly transactions...).

We should ignore such errors.

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8559ad2eaf2a
ensure we deal with transaction.abort() throwing r=leplatrem
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
Blocks: 1629005
You need to log in before you can comment on or make changes to this bug.