Can't type accented characters in HTML form elements

RESOLVED DUPLICATE of bug 162665

Status

Camino Graveyard
HTML Form Controls
--
major
RESOLVED DUPLICATE of bug 162665
16 years ago
16 years ago

People

(Reporter: Stéphane Rieppi, Assigned: Kathleen Brade)

Tracking

Details

(Reporter)

Description

16 years ago
The accentuated characters are faulty sent in forms. The recipient sees only
nonsense garbage.

for instance :

e cute is sent as "é"
e grave is sent as "è"
a grave is sent as "à"

This bug is probably related to bug 161813, which does exactly the same thing
when copy/pasting from Chimera to anything else. This bug prevents a lot of
French-speaking people to use Chimera as they default browser.

Comment 1

16 years ago
Stéphane, what build ID are you reporting this bug against? Are you talking
about not being able to type accented characters, or that they're not submitted
as accented characters somehow?
Summary: Accentuated characters → Accentuated characters
(Reporter)

Comment 2

16 years ago
OK, I realized I was using a really outdated build and half of the problem is gone.

So, with 2002081405, the only remaining problem is that I can't type accented characters 
that are formed with a dead key (^, ¨ or `).

Stéphane

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
There is also a very strange things about special characters like ^ ¨ ~ and
similar. In textedit, when you press ~ (option n 2 times in french) after the
first hit, you see ~ highlighted in yellow showing that it's a special character.
In Chimera (0815) now we can enter them but the display is funny.
Put the cursor in a form field, press
a just to be sure
a again
~ then ^
you'll see the little animation on those characters.
If the TextEdit behavior could rather be implemented that would be great.
(Assignee)

Comment 4

16 years ago
This sounds like a duplicate of a bug on my list.  -->brade
Assignee: bryner → brade

Comment 5

16 years ago
I can *type* accented characters just fine using Chimera/2002082305 on 10.1.5.
Stéphane, are you saying you can't see the accents when you type them, or that
they aren't *submitting* properly?
Summary: Accentuated characters → Can't type accented characters in HTML form elements

Comment 6

16 years ago
He's saying that chimera doesn't do yellow hilighting like cocoa does.

Comment 7

16 years ago
Ah, then this is a dup.

*** This bug has been marked as a duplicate of 162665 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.