If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

History sidebar does not show dates

RESOLVED FIXED

Status

Camino Graveyard
History
--
minor
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: Prachi Gauriar, Assigned: Simon Fraser)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
In the first level of the History sidebar's NSOutlineView, the dates don't show
up. Instead, you only see 0 (Today), 1 (Yesterday), 2 (Two days ago), etc... 

Instead, it should say:

Today
Yesterday
<Weekday, Date>
(Reporter)

Comment 1

15 years ago
Created attachment 95307 [details] [diff] [review]
Patch to CHHistoryDataSource.mm

Basically, when setting the title of an item in the NSOutlineView, check to see
if the item is at level 0. If so, find out how many days ago it was (by getting
the intValue of the string), and create the proper title based on that.

This should be localization friendly.

Comment 2

15 years ago
Another possibility is to just add the history.properties file to embed.jar by
adding the following line into embed-jar.mn:

"locale/XXXX/communicator/history/history.properties, 
XXXX/locale/XXXX/communicator/history/history.properties"

I've no idea which way is better!

See bug_154297 for more details.

Comment 3

15 years ago
History sidebar? In what build is there a history sidebar? I don't see one in
2002081505.
(Assignee)

Comment 4

15 years ago
You have to set the pref: 
user_pref("chimera.show_history", true);
(Reporter)

Comment 5

15 years ago
Simon, have you had a chance to look at this yet? No biggy if you haven't had a
chance yet (since the history sidebar isn't even enabled by default).
heh, i came up with the embed-jar.mn fix on my own. fixed, but we'll need a
different fix for the trunk since we can't just go editing that file willy-nilly.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
yay!

vrfy'd fixed on 10.2.2, with 2002.11.12.04.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

15 years ago
Reopening. This issue has reappeared in Camino build 2003030808 upon merging
with the trunk (as comment #6 predicted). 
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

15 years ago
*** Bug 196552 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

15 years ago
*** Bug 197413 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
I searched for this, I SWEAR! Sorry about the duplicate bidness...
fixed last night
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED

Comment 13

14 years ago
This bug is reappearing again.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.6a) Gecko/20031023
Camino/0.7+
You need to log in before you can comment on or make changes to this bug.