Crash occurs when attempting to copy entire page source content

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: chrispetersen, Assigned: sfraser_bugs)

Tracking

({crash})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build: 2002-08-14-05
Platform: OS X 10.1.5
Expected Results: Selection should be copied to clipboard
What I got: Application crashes

Steps to reproduce:

1) Go to any page.
2) Choose View Page Source from the View menu.
3) Press Command- A to select of the page's content.
4) Press Command- C to copy selection.
5) Crash occurs
(Reporter)

Comment 1

16 years ago
Created attachment 95315 [details]
stack trace
(Reporter)

Updated

16 years ago
Keywords: crash

Comment 2

16 years ago
WorksForMe using Chimera/2002081105.
This would probably be a regression from my checkin for bug 159354, checked in
on the 11th (so it would first appear on builds from the 12th).

Comment 4

16 years ago
Confirmed using Chimera/2002081505, generating same stack.

Comment 5

16 years ago
well it's not just copying page source...find a webpage only with ALOT of text,
try to copy that text and it crashes.
(Assignee)

Comment 6

16 years ago
*** Bug 164277 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

16 years ago
WFM in the latest build (2002-08-29-05).
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 8

16 years ago
I can still repro this, on the source of the mozilla site.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 9

16 years ago
Taking
Assignee: bryner → sfraser
Status: REOPENED → NEW
(Assignee)

Comment 10

16 years ago
Fixed checked in. We were passing a byte count, rather than a character count,
in from the clipboard code.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
another good page to test: http://www.w3.org/TR/html4/
(Reporter)

Comment 12

16 years ago
Verified in the 2002-09-04-05 NB.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.