Closed Bug 1627642 Opened 2 years ago Closed 2 years ago

printing a page loses content

Categories

(Core :: Printing: Output, defect)

74 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1622935

People

(Reporter: justdave, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

  1. Visit https://foundation.mozilla.org/en/blog/what-can-you-tell-me-about-zoom/
  2. Print

Actual results:

The printed version is missing half of the article content when printed from Firefox. If I print from Safari I get the whole thing.

Expected results:

I should be able to print the entire article from Firefox.

The PDF generated from attempting to print from both Firefox and Safari are attached for comparison.

I've seen this on several other sites recently, too. This was actually reported to me by another user who is using the release version of Firefox (74) on Mac (I'm using DevEd (75))

Version: 75 Branch → 74 Branch

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Printing: Output
Product: Firefox → Core

I just reproduced this on the order confirmation screen on https://meijer.com/ after placing a delivery/pickup order. Attempting to print the confirmation screen cuts off the content at the bottom of the first page on the paper, and the second page of the printout is blank.

My workaround for this so far is to use Firefox's "screenshot" feature, have it grab the entire page, then open that file in Safari and print it from there (after screwing with the scaling to get it the right width).

Dave Miller, thanks for reporting this!

In looking at this site: https://foundation.mozilla.org/en/blog/what-can-you-tell-me-about-zoom/

and I believe that this is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=534182

The d-flex class on this page uses display:flex. I used the stylus add-on to force everything to be display:block instead and all of the content showed up in the print.

Marking as a duplicate of 534182

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 534182

Then it's a dupe of bug 939897 (which it's being actively worked on) not the inline-* version of this bug which is different.

Duplicate of bug: 939897

The work-in-progress patches in bug 1622935 can fix the content loss of the page in comment 0 in printing. I'll dup this over bug 1622935.

Duplicate of bug: 1622935
You need to log in before you can comment on or make changes to this bug.