Closed Bug 1627817 Opened 4 months ago Closed 4 months ago

PiP full screen transition is too slow

Categories

(Toolkit :: Video/Audio Controls, defect, P1)

All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla77
Tracking Status
firefox76 --- verified
firefox77 --- verified

People

(Reporter: mstange, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When double-clicking on the small picture-in-picture window on macOS, the screen stays black for an unusually long time during the transition.

You can see Fullscreen toggle timeout markers in the profile: https://perfht.ml/2wWI6ZH

This means that the transition is waiting for an unnecessarily long time because some expected events are not firing.

Here's the code that inserts the Fullscreen toggle timeout marker: https://searchfox.org/mozilla-central/rev/4d2a9d5dc8f0e65807ee66e2b04c64596c643b7a/dom/base/nsGlobalWindowOuter.cpp#4505

It seems to be waiting for a fullscreen-painted observer notification. Which is sent here: https://searchfox.org/mozilla-central/rev/4d2a9d5dc8f0e65807ee66e2b04c64596c643b7a/browser/actors/DOMFullscreenChild.jsm#58

... in response to a DOMFullscreen:Painted message from the content process. So I suppose we need to find out why the content process doesn't send this message for the PiP window.

Duplicate of this bug: 1628118
Duplicate of this bug: 1622544
Blocks: videopip

The DOMFullscreen JSWindowActors, which normally handle this sort of thing,
don't get instantiated for events that fire for a parent process DOM Window.

Assignee: nobody → mconley
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/39d9b2c79c3a
Make sure to fire fullscreen-painted notification when transitioning PiP player window in and out of fullscreen. r=mstriemer
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77

Comment on attachment 9139550 [details]
Bug 1627817 - Make sure to fire fullscreen-painted notification when transitioning PiP player window in and out of fullscreen. r?mstriemer!

Beta/Release Uplift Approval Request

  • User impact if declined: Users that attempt to transition the Picture-in-Picture player window to fullscreen on macOS might find the transition too slow.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky, because the change is very simple - we're sending a signal that the fullscreen transition has finished that we weren't sending before.
  • String changes made/needed: None.
Attachment #9139550 - Flags: approval-mozilla-beta?

Comment on attachment 9139550 [details]
Bug 1627817 - Make sure to fire fullscreen-painted notification when transitioning PiP player window in and out of fullscreen. r?mstriemer!

Approved for 76.0b5.

Attachment #9139550 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Reproduced the issue on Windows 10 and MacOS 10.15 using Firefox Nightly 77.0a1 (20200413034542) and Firefox Beta 76.0b4 (20200412214314)
Verified fixed on Firefox Nightly 77.0a1 (20200420214939) and Firefox 76.0b6 (20200420031429)

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.