Closed Bug 1628024 Opened 8 months ago Closed 8 months ago

Urlbar dropdown degraded to duplicating top sites from new tab page

Categories

(Firefox :: Address Bar, defect)

75 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: remtanmajitenshi, Unassigned)

References

Details

Before 75 urlbar dropdown results were different from new tab page top sites. If I understand correctly, dropdown was filled with frequently typed urls, while top sites by default were most visited urls (?) and also customizable with pinning what you want.
It was very useful because it was possible to have different urls in dropdown results and top sites.
Now urlbar dropdown just duplicates top sites, which is completely useless for me on new tab page (can be argued somewhat useful on tabs with loaded content).
I didn't a find pref in about:config to return previous behavior other than completely disabling new megabar (browser.urlbar.update1), making it impossible to have old dropdown results with new browser.urlbar.openViewOnFocus. Also I see you are planning to remove all those prefs, including browser.urlbar.update1 (Bug 1627969) which will make it impossible to bring back old dropdown results.

So in addition to Bug 1627858 (adding visible preference to current browser.urlbar.openViewOnFocus which is going removed) I suggest to add visible preference (or at least about:config) to control content of urlbar dropdown (old behavior or duplicating top sites).

I concur with @Qwerty. A pref to show typed history (like Vivaldi does by default) is a must for developers and testers. Currently, you need to remember and enter part of the URL to get any history suggestions.

Duplicating the top sites can still be the default behavior, but please provide a pref like this:

if (expanding address bar on focus enabled°) {
  Expanded address bar opens with:
    - Top Sites
    - History
}

°see bug 1627858

Firefox needs this kind of customizability to make the difference with other browsers. As an IT professional, I have other use cases than my parents when using the address bar. Please attend to both.

I suggest changing the title of this bug to "Should have a user visible preference in about:preferences to choose the content of the megabar dropdown" or something similar.

The list we had before was a list of the top frecent pages.
The NewTab page list is also based on that list, so their initial contents are very similar. The NewTab page list though is customizable, while the old one wasn't. That means you can pin and move around pages, you can remove pages, you can also have search shortcuts there.
In practice that means you can have a customizable version of the old list. If you remove any pinned pages from the NewTab page you should end up with the old list (modulo really minor differences).
We actually think the new list gives more value and customization.

Regarding the duplication, the list is not automatically opened in the NewTab page, exactly because it would duplicate contents, on the other side you can now use the Top Sites list from any other tab.

Can you be more specific about why you don't like being able to customize the list to your preference, compared to having a carved in stone list of pages you can't change?

The customization I would like is the option to have no suggestions at all until the user starts typing.
When I type in the address bar I have a goal, and my plan for that goal is to either to search for a string or to type in the start of the URL to find the site I want. A list appearing before I start typing is a distraction I don't want.

Regarding the duplication, the list is not automatically opened in the NewTab page whether or not it would be a duplication. if the Firefox Home Content is just Pocket or if the new tab page is set to a blank page or a custom page the list is not automatically opened even though there would be no duplication.
(I like the current behavior. I'm just pointing out that the behavior doesn't match the stated goal of avoiding duplication in comment 3.)

(In reply to B.J. Herbison from comment #4)

The customization I would like is the option to have no suggestions at all until the user starts typing.

That's Bug 1627858. I'm more curious about the reasons why a customizable list is worse than a non customizable one.

Flags: needinfo?(remtanmajitenshi)

Can you be more specific about why you don't like being able to customize the list to your preference, compared to having a carved in stone list of pages you can't change?

I was using them for different things. I use the New Tab page as sort of an extension of bookmarks: my top options were links to aggregator sites I visit once per day, middle clicking all of them (which you can't do from the URL bar, as it closes after one click). Meanwhile, my highest frecency sites were the ones I typed the URLs of most frequently (I think).

I think I can get close to what I had before here by just moving all my pinned sites under the default sites, though I'm not sure -- the 7 sites in the URL bar include six of my seven top pinned sites, but the 7th is the 8th one on the new tab page -- an unpinned site that was 4th in the previous list. The old style also had 10 sites while the new one has seven, but that's minor.

You could also say that I'd be better served using bookmarks (from the bookmark bar, for instance) for this use-case -- that's probably correct, but it's not the flow I'd become used to. I can get used to this new behaviour as well; I'm just giving an example of why someone might prefer the old style.

Side note: you can still reach the old list by typing a ^ symbol in the urlbar

(In reply to Marco Bonardo [:mak] from comment #7)

Side note: you can still reach the old list by typing a ^ symbol in the urlbar

Thanks! I found a page listing more options -- # looks easier to type on a UK keyboard and returns the same results.

This isn't quite the same as the old list, though -- if I had to guess, ^ gives you the pages you visit the most, whereas the old list was the pages you visited the most by typing the URLs. I've got the same 9 URLs, but they're in a different order.

(In reply to Marco Bonardo [:mak] from comment #3)

The list we had before was a list of the top frecent pages.
The NewTab page list is also based on that list, so their initial contents are very similar. The NewTab page list though is customizable, while the old one wasn't. That means you can pin and move around pages, you can remove pages, you can also have search shortcuts there.
In practice that means you can have a customizable version of the old list. If you remove any pinned pages from the NewTab page you should end up with the old list (modulo really minor differences).
We actually think the new list gives more value and customization.

Regarding the duplication, the list is not automatically opened in the NewTab page, exactly because it would duplicate contents, on the other side you can now use the Top Sites list from any other tab.

(In reply to Marco Bonardo [:mak] from comment #7)

Side note: you can still reach the old list by typing a ^ symbol in the urlbar

First of all, thank you for taking the time to explain the old behavior and the reasoning behind the Top Sites in the address bar. Also, while I know the existence of the ^ operator, I didn't know using it would result in the original list.

Can you be more specific about why you don't like being able to customize the list to your preference, compared to having a carved in stone list of pages you can't change?

Same answer as Chris Midgley in comment #6: I was using the address bar and New Tab Page for different things. I have 18 sites pinned on the New Tab page. My unpinned history starts at position 19, so it won't ever appear in the address bar with its 10-ish results (unless I start typing and there is a match with my history).

So now in FF75, with the Top Sites in the address bar
... I loose the history dropdown which was complementary to my bookmarks/pinned sites (unless I unpin everything on the New Tab page, but what's the point of it then?)
... I win the Top Sites being at my disposal from any tab, like you mentioned.

I can live with the current situation (duplication + ^ operator), but I feel like having the option to choose the content of the dropdown could be advantageous for users who just open a new tab for accessing their pinned Top Sites, and thus want something complementary to appear by default in the address bar dropdown, like their page history. Probably a nice-to-have. Thanks again.

(In reply to Marco Bonardo [:mak] from comment #5)

I'm more curious about the reasons why a customizable list is worse than a non customizable one.

It's not worse, but that's not a full picture of what happened.
Previously, there were two features/places, one was non-customizable and other was customizable.
Now non-customizable one was replaced by customizable one, making both places identical.
So for someone who didn't liked non-customizable feature and didn't needed it, this change is positive.
For someone who found both features useful and used them for different purposes, this change is negative.

Ideally, instead of replacing non-customizable feature with customizable feature (duplicating one feature in two places), there should be even more customization: making it possible to configure two places (address bar dropdown and ntp top sites) independently from each other.
So if someone wants two placed to be identical, they got it.
If someone wants two placed to be different, they got it.

Now I think that customization of content for both places can be based on top sites alone, instead of top sites + non-configurable history. Because top sites has rows, and those rows can be used in this ideal customization.
For example, someone who has two rows of top sites may want to have one of them show in address bar dropdown. I.E. they pin in the first row pages that they want to middle/ctrl-click (as mentioned in comment #6), while in the second row pin (or have them come from history, or mix of both) other pages to appear in address bar dropdown.
In this case we will have both places customizable to user's wishes, which is better than old (non-customizable+customizable) and current (customizable but duplicated in two places) situations.

Flags: needinfo?(remtanmajitenshi)

Thank you a lot for the feedback, I'm turning that to our UX team.

I'm resolving this bug because the current state is what is expected for now, and we don't want to have a preference to flip between old and new contents.

The surprise effect is covered by bug 1628025 and bug 1608418.
Not showing the list automatically is bug 1627858.
The old list can still be used, if you disable Top Sites in the New Tab Page, or with the ^ workaround.

Of course, it sounds like there's will to have more control over what is shown in the urlbar default view, without having to sacrifice one feature for another, or without having to go to about:newTab.
We started brainstorming about that but we don't have a plan yet, so we'll file an implementation bug once we're ready.

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Resolution: --- → WONTFIX

FYI, I filed a bug to bring back the dropmarker list (perhaps even as an option) in bug 1629387.

See Also: → 1629387

(In reply to Marco Bonardo [:mak] from comment #7)

Side note: you can still reach the old list by typing a ^ symbol in the urlbar

So the new plan for UI is to turn Firefox into Lynx? Typing an obscure shorthand vs. pressing a visually intuitive button to open the list of frequent URLs seems to me like an obvious choice, but I guess I'm just a user.

For me the new tab page has the top sites listed and the pre-77 I could open the list of most frequent URLs by a single mouse click. This to me is the biggest gripe with the new address bar. (Even before I was able to fix the visual crap via userChrome.css).

bug 1629387 is tracking the problem, we have a possible solution in mind, so what is suggested here is just workarounds.

You need to log in before you can comment on or make changes to this bug.