Closed Bug 1628069 Opened 4 years ago Closed 4 years ago

Mixed language in settings and menus


(Firefox :: Untriaged, defect)

75 Branch
Not set





(Reporter: mertin, Unassigned)



(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

Updated Firefox to Version 75.
After seeing the first bug part, switched language to German (because English was still shown as selected), then back to English.

Actual results:

Interface showed everything in German, while English was selected as language to be used.

Interface shows parts in English and parts in German.

Expected results:

(1) Interface language should have stayed English.
(2) Interface language should have completely switched to English.

hi, does the workaround from help you resolving the issue?

Did the "firefox.exe -purgecache" but it did not change anything.
But when trying to update the language pack, as suggested in the thread, it says that the language pack is not compatible with Firefox 75.

Looks like we don't have updated language packs on AMO?

Update: there is an updated version, but it doesn't look like the one offered by default by AMO

I've installed the language on my machine via Preferences, and that results in 75.0buildid20200403170909 being installed.

Ever confirmed: true
Flags: needinfo?(bugspam.Callek)

I'm confused. History says that the language pack was updated 23 days ago, but the compatibility in manifest.json is set to 75.*.

I tried installing 75.0 and switching to English, and it works fine for me.

Can you try removing English from the list of languages available (click Set Alternatives…, then remove the language, and add it back).

Summary: Firefox in two languages → Mixed language in settings and menus

Hey sorry. I got kinda frustrated last night and uninstalled Firefox and reinstalled with English as standard language.
So I can not try that. In retrospect that was probably a dumb idea, as far as trying to figure out where the problem was.

What is interesting though is that the interface switched back to fully German while using the browser. I did not restart it or anything but the context menu, which was the only thing that was displaying in English before, switched to German.

"Inspired" by comment #3 I looked at what language packs I had installed (Preferences > Extensions & Themes) and the (English (US) Language Pack)[] was disabled because it was for v74.0, so I updated it and the following problems went away: Bottom row of buttons in Set Alternatives... is now in English, permission "notifications" are in English, the header "Protections for <website>" under the shield is now in English (I think it was in Swedish before) but all of the other information in the box is still in Swedish, the file input (Browse... No file selected) is in English. The hamburger menu is still in Swedish.

Regarding comment #4, I have two languages listed in that popup, English (first) and Swedish. Neither of them can be removed. If I add a third language, the third language can be removed, but only that one.

Can you try starting the app from a Terminal adding the -purgecaches option. Follow these instructions and replace -P with -purgecaches

It's normal that you can't remove one of the languages (that's the language of the build itself), not sure it's expected that two of them should not be removable.

To be clear: do you have the rights to remove Firefox and install it in English? That would solve the problem for good.

I did the -purgecaches before what I did in comment #7, both with .../firefox and firefox-bin, I don't know what the difference is, both versions of the command opened the browser, but I don't think I could see any difference with the languages (if I had I probably would've posted a comment about that) but I ran the command again now and it worked, everything is in English now!

Thanks. I'm going to dupe this against the bug around language pack updates. Hopefully we'll also have a way to clear the cache from about:support (bug 1569653).

Also clearing NI for Callek, apparently different people are seeing different things in AMO.

Closed: 4 years ago
Flags: needinfo?(bugspam.Callek)
Resolution: --- → DUPLICATE

Nice, may I ask what AMO is short for?

AMO is (also links in comment 3)

You need to log in before you can comment on or make changes to this bug.