geting long query results makes XWrapper eat all cpu

VERIFIED DUPLICATE of bug 7724

Status

()

Core
HTML: Parser
P3
normal
VERIFIED DUPLICATE of bug 7724
19 years ago
18 years ago

People

(Reporter: moshev, Assigned: harishd)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
go to http://www.deja.com
press search (upper right corner)
check all in (recent/old/all) combobox,
type some generic query (e.g. javascript)
get results.
now try to do anything on the resulted links,
for example use right mouse click to open link in new window.

It will be impossible. when checking top, XWrapper is now eating <90% CPU,
and working with X is almost impossible.

Comment 1

19 years ago
I suggest looking at bug 16768 and bug 7724, this is almost certainly a dup, in
which case the long query results are not the problem but incorrect HTML. Also
try the attatchment on bug 16768 and look at the description there for a test if
this is a dup.

I'd do this myself but I don't have access to a Linux machine right now :|

Updated

19 years ago
Assignee: don → harishd
Component: Browser-General → Parser
QA Contact: leger → janc

Comment 2

19 years ago
Per spyysalo@cs.helsinki.fi's comment, reassigning to janc to determine whether
this is a dupe. (It looks like one to me, but I'd prefer deferring to the
component QA owner.)
(Assignee)

Comment 3

19 years ago
This is what I did:

Opened www.deja.com, changed the selection, in the search combo box, to "all",
typed "javascript" in the TEXTAREA and clicked search.
Now, on the resulting page I clicked on one of the links and everything froze.

Took a glimpse on the stack and this is what I found

nsWindow::WindowProc(void * 0x00220948, unsigned int 70, unsigned int 0, long
1239016) line 589 + 31 bytes
USER32! 77e71ab7()
USER32! 77e72ffa()
NTDLL! 77f7624f()
nsView::SetPosition(nsView * const 0x011a07b0, int 10350, int 6240) line 875
nsViewManager::MoveViewTo(nsViewManager * const 0x022005c0, nsIView *
0x011a07b0, int 10350, int 6240) line 1921
nsFrame::DidReflow(nsFrame * const 0x011844c4, nsIPresContext & {...}, int 1)
line 1205
nsFormControlFrame::DidReflow(nsFormControlFrame * const 0x011844c4,
nsIPresContext & {...}, int 1) line 195 + 17 bytes
nsContainerFrame::DidReflow(nsContainerFrame * const 0x0112c734, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x0112c6a4, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x0111e3d4, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012dce44, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012dc1d4, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012dcf64, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012dbae4, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012db944, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012db664, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012db5f4, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012db4a4, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012db424, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012db334, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012db2a4, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x012db224, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x0121fcf4, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x0121e514, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x0121e2f4, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x0121d514, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x0121d484, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x011ec254, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x011b57b4, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x011b5124, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x011b5f94, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x02232574, nsIPresContext
& {...}, int 1) line 120
nsContainerFrame::DidReflow(nsContainerFrame * const 0x02231df4, nsIPresContext
& {...}, int 1) line 120
nsAreaFrame::DidReflow(nsAreaFrame * const 0x02231df4, nsIPresContext & {...},
int 1) line 376
nsContainerFrame::DidReflow(nsContainerFrame * const 0x0222fe34, nsIPresContext
& {...}, int 1) line 120
nsScrollFrame::DidReflow(nsScrollFrame * const 0x0222f574, nsIPresContext &
{...}, int 1) line 171
ViewportFrame::Reflow(ViewportFrame * const 0x0222fdc4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 528
nsHTMLReflowCommand::Dispatch(nsHTMLReflowCommand * const 0x023a3530,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsSize & {...},
nsIRenderingContext & {...}) line 141
PresShell::ProcessReflowCommands(PresShell * const 0x02201780) line 1431
PresShell::ExitReflowLock(PresShell * const 0x02201780) line 671
PresShell::ContentStatesChanged(PresShell * const 0x02201788, nsIDocument *
0x022bfd10, nsIContent * 0x022d734c, nsIContent * 0x00000000) line 1822
nsDocument::ContentStatesChanged(nsDocument * const 0x022bfd10, nsIContent *
0x022d734c, nsIContent * 0x00000000) line 1506
nsEventStateManager::SetContentState(nsEventStateManager * const 0x0223e7a0,
nsIContent * 0x022d734c, int 3) line 1448
nsHTMLAnchorElement::HandleDOMEvent(nsHTMLAnchorElement * const 0x022d734c,
nsIPresContext & {...}, nsEvent * 0x0012fcec, nsIDOMEvent * * 0x0012f9cc,
unsigned int 2, nsEventStatus & nsEventStatus_eIgnore) line 354
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012fcec,
nsIDOMEvent * * 0x0012f9cc, unsigned int 2, nsEventStatus &
nsEventStatus_eIgnore) line 796 + 39 bytes
nsHTMLLIElement::HandleDOMEvent(nsHTMLLIElement * const 0x022d76fc,
nsIPresContext & {...}, nsEvent * 0x0012fcec, nsIDOMEvent * * 0x0012f9cc,
unsigned int 2, nsEventStatus & nsEventStatus_eIgnore) line 232
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012fcec,
nsIDOMEvent * * 0x0012f9cc, unsigned int 2, nsEventStatus &
nsEventStatus_eIgnore) line 796 + 39 bytes
nsHTMLParagraphElement::HandleDOMEvent(nsHTMLParagraphElement * const
0x022d81cc, nsIPresContext & {...}, nsEvent * 0x0012fcec, nsIDOMEvent * *
0x0012f9cc, unsigned int 2, nsEventStatus & nsEventStatus_eIgnore) line 216
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012fcec,
nsIDOMEvent * * 0x0012f9cc, unsigned int 2, nsEventStatus &
nsEventStatus_eIgnore) line 796 + 39 bytes
nsHTMLTableElement::HandleDOMEvent(nsHTMLTableElement * const 0x022d832c,
nsIPresContext & {...}, nsEvent * 0x0012fcec, nsIDOMEvent * * 0x0012f9cc,
unsigned int 2, nsEventStatus & nsEventStatus_eIgnore) line 1300
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012fcec,
nsIDOMEvent * * 0x0012f9cc, unsigned int 2, nsEventStatus &
nsEventStatus_eIgnore) line 796 + 39 bytes
nsHTMLTableSectionElement::HandleDOMEvent(nsHTMLTableSectionElement * const
0x022d884c, nsIPresContext & {...}, nsEvent * 0x0012fcec, nsIDOMEvent * *
0x0012f9cc, unsigned int 2, nsEventStatus & nsEventStatus_eIgnore) line 371
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012fcec,
nsIDOMEvent * * 0x0012f9cc, unsigned int 2, nsEventStatus &
nsEventStatus_eIgnore) line 796 + 39 bytes
nsHTMLTableRowElement::HandleDOMEvent(nsHTMLTableRowElement * const 0x022db9ec,
nsIPresContext & {...}, nsEvent * 0x0012fcec, nsIDOMEvent * * 0x0012f9cc,
unsigned int 2, nsEventStatus & nsEventStatus_eIgnore) line 736
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012fcec,
nsIDOMEvent * * 0x0012f9cc, unsigned int 2, nsEventStatus &
nsEventStatus_eIgnore) line 796 + 39 bytes
nsHTMLTableCellElement::HandleDOMEvent(nsHTMLTableCellElement * const
0x022dc670, nsIPresContext & {...}, nsEvent * 0x0012fcec, nsIDOMEvent * *
0x0012f9cc, unsigned int 2, nsEventStatus & nsEventStatus_eIgnore) line 556
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012fcec,
nsIDOMEvent * * 0x0012f9cc, unsigned int 2, nsEventStatus &
nsEventStatus_eIgnore) line 796 + 39 bytes
nsHTMLFontElement::HandleDOMEvent(nsHTMLFontElement * const 0x022dc6ec,
nsIPresContext & {...}, nsEvent * 0x0012fcec, nsIDOMEvent * * 0x0012f9cc,
unsigned int 2, nsEventStatus & nsEventStatus_eIgnore) line 374
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012fcec,
nsIDOMEvent * * 0x0012f9cc, unsigned int 2, nsEventStatus &
nsEventStatus_eIgnore) line 796 + 39 bytes
nsHTMLAnchorElement::HandleDOMEvent(nsHTMLAnchorElement * const 0x022dcaac,
nsIPresContext & {...}, nsEvent * 0x0012fcec, nsIDOMEvent * * 0x0012f9cc,
unsigned int 2, nsEventStatus & nsEventStatus_eIgnore) line 336 + 31 bytes
nsGenericDOMDataNode::HandleDOMEvent(nsIPresContext & {...}, nsEvent *
0x0012fcec, nsIDOMEvent * * 0x0012f9cc, unsigned int 1, nsEventStatus &
nsEventStatus_eIgnore) line 786 + 39 bytes
nsTextNode::HandleDOMEvent(nsTextNode * const 0x022dce5c, nsIPresContext &
{...}, nsEvent * 0x0012fcec, nsIDOMEvent * * 0x00000000, unsigned int 1,
nsEventStatus & nsEventStatus_eIgnore) line 204
PresShell::HandleEvent(PresShell * const 0x02201784, nsIView * 0x02231b20,
nsGUIEvent * 0x0012fcec, nsEventStatus & nsEventStatus_eIgnore) line 2200 + 39
bytes
nsView::HandleEvent(nsView * const 0x02231b20, nsGUIEvent * 0x0012fcec, unsigned
int 8, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 834
nsView::HandleEvent(nsView * const 0x0222f6b0, nsGUIEvent * 0x0012fcec, unsigned
int 8, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 819
nsView::HandleEvent(nsView * const 0x0222f5d0, nsGUIEvent * 0x0012fcec, unsigned
int 8, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 819
nsView::HandleEvent(nsView * const 0x022013b0, nsGUIEvent * 0x0012fcec, unsigned
int 28, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 819
nsViewManager::DispatchEvent(nsViewManager * const 0x022005c0, nsGUIEvent *
0x0012fcec, nsEventStatus & nsEventStatus_eIgnore) line 1739
HandleEvent(nsGUIEvent * 0x0012fcec) line 63
nsWindow::DispatchEvent(nsWindow * const 0x02230154, nsGUIEvent * 0x0012fcec,
nsEventStatus & nsEventStatus_eIgnore) line 401 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fcec) line 422
nsWindow::DispatchMouseEvent(unsigned int 302, nsPoint * 0x00000000) line 3394 +
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 302, nsPoint * 0x00000000) line
3612
nsWindow::ProcessMessage(unsigned int 513, unsigned int 1, long 31981827, long *
0x0012fee4) line 2623 + 24 bytes
nsWindow::WindowProc(void * 0x002e0646, unsigned int 513, unsigned int 1, long
31981827) line 579 + 27 bytes
USER32! 77e71250()
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
okay, spoke too soon, it did not freeze but rather took a long time to load.

Similar to bug 16768.

*** This bug has been marked as a duplicate of 7724 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
[bugday] verified duplicate. Dejanews stall bug.
You need to log in before you can comment on or make changes to this bug.