Closed Bug 1628239 Opened 4 months ago Closed 3 months ago

'TypeError: oldOptionalPermissions is undefined' when upgrading from 74.0.1 to 75.

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- fixed

People

(Reporter: standard8, Assigned: mixedpuppy)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

I don't know if this causes a user-facing issue or not, but I received a console log of a user from just after upgrading from 74.0.1 to 75. On that log there's a lot of messages about oldOptionalPermissions being undefined for various add-ons.

It is unclear what the effect is, but it looks like some of the permissions upgrade process might not run at a quick glance?

Seems to happen for at least all the theme and search-engine built-in add-ons, I don't know about custom ones.

1586311813594	addons.xpi	WARN	Exception running bootstrap method update on default-theme@mozilla.org: TypeError: oldPermissions is null(resource://gre/modules/Extension.jsm:707:7) JS Stack trace: intersectPermissions@Extension.jsm:707:7
migratePermissions@Extension.jsm:735:34
update@Extension.jsm:1643:25
callBootstrapMethod@XPIProvider.jsm:1795:33
_install@XPIProvider.jsm:1970:18
update@XPIProvider.jsm:2078:17
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
Assignee: nobody → mixedpuppy
Priority: -- → P1
Component: General → Add-ons Manager
Product: WebExtensions → Toolkit

FWIW I think I saw one yesterday that was oldPermissions was undefined.

Blocks: 1630694
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b22e071cc343
fix extension permission migration for permissionless extensions r=robwu
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
Blocks: 1636177
See Also: → 1643854
See Also: → 1654812
You need to log in before you can comment on or make changes to this bug.