Closed Bug 1628264 Opened 3 years ago Closed 3 years ago

Crash in [@ IPCError-browser | ShutDownKill | RtlpWakeConditionVariable | nsThread::Dispatch]

Categories

(Core :: Gecko Profiler, defect)

Unspecified
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1613798

People

(Reporter: sg, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-81c8d714-7206-4aea-a9cf-0061f0200406.

Top 10 frames of crashing thread:

0 ntdll.dll RtlpWakeConditionVariable 
1 xul.dll nsThread::Dispatch xpcom/threads/nsThread.cpp:719
2 xul.dll mozilla::ChildProfilerController::ShutdownAndMaybeGrabShutdownProfileFirst tools/profiler/gecko/ChildProfilerController.cpp:55
3 xul.dll mozilla::ChildProfilerController::GrabShutdownProfileAndShutdown tools/profiler/gecko/ChildProfilerController.cpp:44
4 xul.dll mozilla::dom::ContentChild::ShutdownInternal dom/ipc/ContentChild.cpp:2920
5 xul.dll mozilla::dom::ContentChild::RecvShutdown dom/ipc/ContentChild.cpp:2865
6 xul.dll mozilla::dom::PContentChild::OnMessageReceived ipc/ipdl/PContentChild.cpp:11196
7 xul.dll mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2111
8 xul.dll mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:1990
9 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1220

This has peaked in two recent nightlies on a single installation, but has been occurring occassionally with older nightlies as well. The oldest build id I found was 20200312093312, but this might coincide with changes in the format of ShutdownKill crash signatures.

Yep, looks like a dup of bug 1613798 due to a signature change. I'm moving the signature there.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.