Closed Bug 1628627 Opened 1 year ago Closed 11 months ago

[mozproxy] Mitmproxy is ignoring 301 requests

Categories

(Testing :: Mozbase, defect, P1)

Version 3
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Bebe, Assigned: Bebe)

References

Details

Attachments

(1 obsolete file)

Update alternate server for mitmproxy to reply 3XX responses

Pushed by fstrugariu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/04bda73f9d19
[mozproxy] Mitmproxy is ignoring 301 requests r=perftest-reviewers,tarek,AlexandruIonescu
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
Duplicate of this bug: 1634334
Regressions: 1636048

as Bug 1624813 - Update raptor tests to mitm 5.0.1 was backedout can we also get this backed out?

Flags: needinfo?(malexandru)
Flags: needinfo?(malexandru) → needinfo?(sheriffs)

Note that this patch also needs to be backed-out from beta.

Backed out on autoland and will get to m-c with the next merge: https://hg.mozilla.org/integration/autoland/rev/8f68705097b4bf88cd61b43b14401cde98ac75b6

Status: RESOLVED → REOPENED
Flags: needinfo?(sheriffs)
Resolution: FIXED → ---
Whiteboard: [checkin-needed-beta]
Status: REOPENED → ASSIGNED
Target Milestone: mozilla77 → ---
Whiteboard: [checkin-needed-beta]
Attachment #9143012 - Attachment is obsolete: true

As this was a solution for a issue identified by mitm 5.0.1 and was backed out marking this as won't fix

Status: ASSIGNED → RESOLVED
Closed: 1 year ago11 months ago
Resolution: --- → WONTFIX

But we still want to upgrade to 5.0.1. So isn't that patch not needed then?

Flags: needinfo?(fstrugariu)

that was a temp hack to make 5.0.1 work with 4.0.4 recordings

as we would have 5.1.1 now we will re-investigate this

Flags: needinfo?(fstrugariu)
You need to log in before you can comment on or make changes to this bug.