Closed Bug 1628889 Opened 1 year ago Closed 1 year ago

Intermittent comm/mail/components/preferences/test/browser/browser_*.js | undefined assertion name - Got true, expected false

Categories

(Thunderbird :: Preferences, defect, P5)

defect

Tracking

(thunderbird78 fixed)

RESOLVED FIXED
Thunderbird 79.0
Tracking Status
thunderbird78 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: darktrojan)

References

Details

(Keywords: intermittent-failure, leave-open)

Attachments

(1 file)

I am somewhat hopeful this will stop all of the failures caused by the preferences tab failing to scroll at opening. If not, it should at least fail with a more useful error message.

Assignee: nobody → geoff
Attachment #9155898 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9155898 [details] [diff] [review]
1628889-preferences-scroll-1.diff

Review of attachment 9155898 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r=mkmelin
Attachment #9155898 - Flags: review?(mkmelin+mozilla) → review-
Comment on attachment 9155898 [details] [diff] [review]
1628889-preferences-scroll-1.diff

I'm going to assume that you meant + not -.
Attachment #9155898 - Flags: review- → review+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/2736897d09fc
Try to fix preferences tests that fail to scroll when opening the preferences tab. r=mkmelin

Duplicate of this bug: 1634261
Summary: Intermittent comm/mail/components/preferences/test/browser/browser_general.js | undefined assertion name - Got true, expected false → Intermittent comm/mail/components/preferences/test/browser/browser_*.js | undefined assertion name - Got true, expected false

Correct assumption :)

No failures in this or bug 1634261 since landing. I'm calling it fixed.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 79.0
Comment on attachment 9155898 [details] [diff] [review]
1628889-preferences-scroll-1.diff

This is just fixing a frequent test failure. There is a minor change to production code but it's not risky.
Attachment #9155898 - Flags: approval-comm-beta?
Comment on attachment 9155898 [details] [diff] [review]
1628889-preferences-scroll-1.diff

Approved for beta
Attachment #9155898 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.