Closed Bug 1628957 Opened 2 years ago Closed 2 years ago

Firefox Nightly quits on start due to missing profile

Categories

(Toolkit :: Startup and Profile System, defect)

75 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1551773

People

(Reporter: erwinm, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

To nail down regression dates, tried to install Firefox from here:

https://download-installer.cdn.mozilla.net/pub/firefox/nightly/2020/02/2020-02-11-21-54-52-mozilla-central/

Actual results:

It gives an error saying "Your Firefox profile cannot be loaded. It may be missing or inaccessible.," and quits.

Expected results:

If it needs to create a new profile it should do that.

I can work around this by editing profiles.ini

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit

Resetting severity to default of --.

The priority flag is not set for this bug.
:mossop, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dtownsend)

What is the actual problem here, it isn't clear how to reproduce this.

Flags: needinfo?(dtownsend) → needinfo?(erwinm)

It's that it quits on start, which makes it hard to use to nail down regression dates.

Flags: needinfo?(erwinm)

I may have deleted an extra profile from the previous time I'd tried Nightly.

Ok, but you mention a missing profile, what do you mean by that?

Without clear steps to reproduce we can't proceed here.

I guess (1) use Nightly, (2) delete Nightly and delete extra profile, (3) reinstall Nightly, (4) start Nightly.

How are you deleting the profile?

~/Library/Application_Support/Firefox/Profiles

found the extra profile, deleted it.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1551773
You need to log in before you can comment on or make changes to this bug.