Manage Bookmarks Drag onto folder does not target folder

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: lindyboi, Assigned: sfraser_bugs)

Tracking

Details

(Reporter)

Description

16 years ago
Milestone: Chimera 0.4

Drag bookmark onto bookmark folder

Expected: Folder highlights, bookmark insertion point within folder

Actual result: No highlight, bookmark insertion is BEFORE folder

Comment 1

16 years ago
Will, Chimera tries to guess where the bookmark should be dropped. If you move
the mouse cursor down slightly, you'll see the insertion point show below the
folder.

However, I do see that the folder doesn't highlight. I notice that the
disclosure triangle of a closed folder will highlight when it's going to spring
open during hover, though.

This bug could be changed to be about highlighting the folder.
(Reporter)

Comment 2

16 years ago
Okay, changed the description.  Greg described the current behaviour.  An active
drag (where the items actually move as the user drags) would make the current
behaviour okay, but a ghost drag should target the UI element at the cursor.
Summary: Manage Bookmarks Drag & Drop unexpected behaviour → Manage Bookmarks Drag onto folder does not target folder
I'm not sure if this applies for Jaguar only, but when dragging a bookmark to a
closed folder, it will blink in red twice and then open, so it *does* highlight.
Open folders will *not* be hightlighted though, which certainly would be a good
idea.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

16 years ago
*** Bug 180435 has been marked as a duplicate of this bug. ***
#3 is what I see.
still true 2003090102 on 10.2.6.

Comment 6

15 years ago
I think that the current behaviour is the default for the Cocoa widget in
question (FYI).

Comment 7

14 years ago
Camino is now at 0.8+ and most peopl work on 10.2 and 10.3 now. Currently in the
bookmark manager and the bookmark bar it's clearly indicated where the bookmarks
will be created so I will mark as WFM.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.