Closed Bug 1629281 Opened 4 months ago Closed 4 months ago

MSI Installer for Firefox

Categories

(Firefox :: Installer, enhancement)

75 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 231062

People

(Reporter: deluxe, Unassigned)

Details

Attachments

(1 file)

49.49 KB, application/x-7z-compressed
Details
Attached file Firefox 75.0.7z

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

Downloaded the MSI installer of Firefox and recognized that it's just an EXE wrapper instead of a real MSI installer.

Actual results:

The MSI installer extracted an EXE installer and installed it the EXE way.

Expected results:

MSI installer should behave like a MSI installer that could be modified by transform files.

Attached you find my MSI installer sources for Firefox x86/x64.
It lacks of

  • Default Browser Agent scheduled task (maybe this could help: https://stackoverflow.com/questions/33174887/wix-create-scheduled-task)
  • installation ID (could be solved by setting a WiX variable in a custom action at the beginning of the installation, but not neccesary for enterprise deployment imho)
  • installation/update of new versions (this is an Windows Installer specific issue that couldn't be solved afaik). Upgrade should be done by group policy with remove/new installation instead of updating. In-app updating could be done by MSP patch files but is not possible with group policy software installation.

To build

  • extract "core" directory of the exe-installer to source_x86 or source_x64
  • run build-wxs.bat
  • remove components of firefox.exe and helper.exe from files.wxs, they are defined in Product.wxs (alternative: remove both files before running build-wxs.bat and add it afterwards)
  • run build.bat

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Installer

Thanks for submitting this! There's a few reasons why this work isn't really something we can ship as it is, but the biggest is one you've already pointed out, which is update support. And as you've also pointed out, it doesn't appear solvable. In fact in the past when we've looked into shipping a more feature-complete MSI, we identified the same problem and it effectively stopped those efforts; we're not willing to ship something which creates an installation that cannot be updated in place. Even using MSP files is difficult because we have an existing update system (which we also use on other platforms) that those really don't fit into. Much of this could be worked around by treating the MSI and its patching system as its own independent thing separate from the existing install/update stack, but we don't have the resources to properly maintain two independent stacks like that.

Again, thanks for the submission, and I hope it can prove useful to you in your own work (or others'). It just isn't something that we're able to ship as an official Firefox installer.

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: MSI

FYI, I had asked Martin to submit this so that we could see what he had done and for Molly to provide input. I wonder if it's worth reaching out to Microsoft to find out if there is something around updating that we have missed?

You need to log in before you can comment on or make changes to this bug.