address sent still have the original autocomplete input data folowed by ">>"

RESOLVED DUPLICATE of bug 103917

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 103917
16 years ago
9 years ago

People

(Reporter: Jean-Francois Ducarroz, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
mozilla1.3beta
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
1) open a new compose window
2) type the begining of an address which cause the autocomplete to use ">>" like:
   jfd >> Jean-Francois Ducarroz <ducarroz@netscape.com>
3) do not press tab or enter, do not click on another text field or in the
message body
4) click the Send button
==> the message is send with the address containing the user input!!

The address should have benn cleanup.

Comment 1

15 years ago
I'm seeing the same (Win2k, Moz 1.2 final).  Testing a message to myself, I wind
up with 
jroberts >> Jason Roberts <jroberts@forumone.com>
in the To: line.

I occasionally see this under less strict conditions than the original reporter
mentions.  It seems that sometimes if I tab out of the address box while the
auto-complete is happening, I still get the auto-complet stuff.  I haven't quite
nailed down exactly when it happens, but it seems to occur when I'm moving
quickly.  I was noticing this in 1.2b as well.
(Assignee)

Comment 2

15 years ago
The original problem still exist despite the recent work I did for bug 182321
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.3beta

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 103917 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.