Closed Bug 16294 Opened 20 years ago Closed 20 years ago

[tree] categories in prefs disappear

Categories

(SeaMonkey :: Preferences, defect, P2, critical)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: M.Meyer, Assigned: alecf)

References

()

Details

Attachments

(1 file)

After doubleclicking on a category inside the preferences-box, the "under-
categories" don't reappear (but they are still clickable). Perhaps look at
http://troubadix.netlantic.de/mozilla/03.gif, there it's easy to see (already
closed and reopened categories: Appearance and Navigator).
I'm using the M10-Build.
Assignee: neeti → matt
Component: libPref → Pref UI
Assignee: matt → hyatt
this is a tree widget problem
Hyatt? Have any ideas?  I know your wrist hurts but i can
do the typing for you.
Severity: normal → critical
Priority: P3 → P1
Summary: categories in preferences-box disappear → Dogfood: categories in prefs disappear, crash on click
Target Milestone: M11
I just crashed twice trying to reproduce this.  I saw the child nodes disappear,
but crashed clicking in the blank area to get the content back. Changing to
P1/Critical, targetting M11, putting on dogfood radar.
Assignee: hyatt → matt
reassigning to matt. Thanks for volunteering to type for this. Please grab hyatt
when you are ready.
Whiteboard: [PDT+]
*** Bug 17178 has been marked as a duplicate of this bug. ***
Assignee: matt → alecf
Summary: Dogfood: categories in prefs disappear, crash on click → categories in prefs disappear, crash on click
Giving to alekf since he is the owner of the
tree widget.  Plus it does not crash so undoing dogfood.
Status: NEW → ASSIGNED
Target Milestone: M11 → M12
not crashing, moving off M11 radar.
this problem may have gone away.
M.Meyer - are you still seeing this?
Summary: categories in prefs disappear, crash on click → categories in prefs disappear
It's not crashing for me either, so I'm taking that out of the bug summary. I do
see the children disappearing when their parent is collapsed and re-expanded.
Clicking on the children seems to work ok, though, even though I can't see them.
Whiteboard: [PDT+] → [PDT+] 12/3
Summary: categories in prefs disappear → [tree] categories in prefs disappear
I see something very similar in mail/news - hide/show your top level server and
items like inbox do not show, unless you close and re-open the top level parent.
phil was seeing this yesterday too. Have you tried today's build? There have
been some tree and some table changes that should make inserting content work a
little better.
Priority: P1 → P2
*** Bug 18818 has been marked as a duplicate of this bug. ***
so ben goodger should be checking some stuff in in the coming week that changes
the pref window's tree to be generated from an RDF datasource... this may fix
the problem (though static trees will not exist in the product!)
Whiteboard: [PDT+] 12/3
Target Milestone: M12 → M13
This was taken off dogfood because the crash was fixed, I'm going to take off
PDT+ and move to M13 because this ONLY affecting preferences, and ONLY if
someone goes and double-clicks a category.

If anyone thinks this is actually a dogfood issue, mark it as such and PDT will
reevaluate
Hyatt fixed this the other day.
This should be marked fixed.
oh! I'll check this out and reassign/mark fixed
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
hyatt fixed this last week.
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
Sorry for the spam. changing qa contact.
QA Contact: paulmac → sairuh
verif.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.