All users were logged out of Bugzilla on October 13th, 2018

[blackwell.co.uk] Cannot use Search tools - performing a Search returns browser to index page

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: ed, Assigned: Matti)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020815
BuildID:    2002081508

Cannot use Search tools - performing a Search returns browser to index page

Reproducible: Always
Steps to Reproduce:
1. Visit http://bookshop.blackwell.co.uk/bobuk/scripts/welcome.jsp
2. Type a search term in 'Quicksearch' input box
3. Hit 'Search' button

Actual Results:  Browser returned to index page
http://bookshop.blackwell.co.uk/bobuk/scripts/welcome.jsp

Expected Results:  Search results should have been displayed

This site works fine in IE, Opera and Lynx.
wfm, 2002081413, Linux

Comment 2

16 years ago
WFM Win98 in Moz 1.1beta.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

16 years ago
Aha! WFM 2002081209
Does NOT WFM 2002081308 or 2002081508 (both WinXP)

Respectfully suggest this cannot really be considered WFM until current Windows
builds tested.
(Reporter)

Comment 4

16 years ago
Further build WFMs:

2002072104 (1.1 beta): works (as in comment #2)
2002081209 (nightly): works

2002081308: does NOT work
2002081508: does NOT work
2002081604: does NOT work

I'd say it appears that something got added to the Windows binaries on the 12th
or 13th. I do not have the programming skills to work out what that might be.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

16 years ago
WFM, trunk build 2002081904 - WinXP.
(Reporter)

Comment 6

16 years ago
Right...I think I'm a little closer to working out what's going on - it's to do
with character encoding.

When I view the page Mozilla uses the charset ISO-8859-15 (due to a meta tag).

If I switch charset to ISO-8859-1 or UTF-8 the form works. Also, (a far quicker
way of checking) the css style rules suddenly start working and the page looks
totally different.

Could anyone who tests this bug make sure that they are viewing the page in
ISO-8859-15?

Also, does this need to be refiled into a different component?
(Reporter)

Comment 7

16 years ago
OK, it works now. Whatever it was has been fixed I guess.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.