Closed Bug 1629533 Opened 3 months ago Closed 2 months ago

macOS Share menu icons are missing

Categories

(Core :: Widget: Cocoa, defect, P1)

77 Branch
Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- verified
firefox78 --- verified

People

(Reporter: chuck, Assigned: spohl)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image example.png

On 77 Nightly, most of the sharing icons in the macOS are not displaying for me. This creates visual imbalance, and also makes it challenging to scan the list and find which option you're looking to choose.

I likely got the component for this wrong, but it's not entirely clear where it belongs. ni?dolske to help find the right home.

Flags: needinfo?(dolske)
Flags: needinfo?(dolske) → needinfo?(adw)

Oh sorry I misread that as the App buttons...

Moving this to General for now since it has no house...

Component: Address Bar → General
Flags: needinfo?(adw)
Component: General → Widget: Cocoa
Product: Firefox → Core
Priority: -- → P2
Regressed by: 1561756

13:19.76 INFO: Narrowed integration regression window from [18f3d786, 3e22c91c] (3 builds) to [88737086, 3e22c91c] (2 builds) (~1 steps left)
13:19.76 INFO: No more integration revisions, bisection finished.
13:19.76 INFO: Last good revision: 88737086fe42e08a37bda13eb040a3e770017987
13:19.76 INFO: First bad revision: 3e22c91c3b04f6f4d6e0d172c890b02ee59f2eac
13:19.76 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=88737086fe42e08a37bda13eb040a3e770017987&tochange=3e22c91c3b04f6f4d6e0d172c890b02ee59f2eac

The console logs the following error for the icons that don't draw properly:

CGImageDestinationFinalize failed for output type 'public.tiff'

I have a patch that fixes this and (I believe) also maintains the improvements that were intended in bug 1561756, where this issue was introduced. I'll have :mstange look this over on Phabricator.

Assignee: nobody → spohl.mozilla.bugs
Priority: P2 → P1
Pushed by spohl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a13d22a758e1
Fix an issue that prevented some icons from drawing in the macOS share menu. r=mstange
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

Stephen, this is marked as P1 affecting 77, would it be a safe uplift to beta? Thanks

Flags: needinfo?(spohl.mozilla.bugs)

Comment on attachment 9142240 [details]
Bug 1629533: Fix an issue that prevented some icons from drawing in the macOS share menu. r=mstange

Beta/Release Uplift Approval Request

  • User impact if declined: Some icons in the macOS share menu would not be shown.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: On the right side of the URL bar, click on the three dots and then "Share". An icon for every menu entry should be shown.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This change is isolated to a single function that converts an NSImage to a Base64 representation which is only used by the share menu in question. This code is not shared elsewhere.
  • String changes made/needed: none
Flags: needinfo?(spohl.mozilla.bugs)
Attachment #9142240 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9142240 [details]
Bug 1629533: Fix an issue that prevented some icons from drawing in the macOS share menu. r=mstange

Low risk fix for a visible macos regression, uplift approved for 77 beta 2, thanks.

Attachment #9142240 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I've managed to reproduce this issue using Firefox 77.0a1 (BuildId:20200413225327) on macOS 10.14.5

This issue is verified fixed using Firefox 78.0a1 (BuildId:20200505213825) and Firefox 77.0b2 (BuildId:20200505174119).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.