Strange and random behavior when rolling the mouse wheel on a page that has scrollable list items (e.g. <select . . .>)

VERIFIED DUPLICATE of bug 33732

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 33732
16 years ago
13 years ago

People

(Reporter: Steven R Meyer, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

When using the mouse wheel to scroll, sometimes it will scroll the page in the
window, and sometimes it will scroll one or another of the list items on the
form (<select...>) or text items (<textarea....>).  In Netscape 4.7x, the item
scrolled is the one that has keyboard focus (i.e. where the user clicked).  In
Mozilla 2002053012, it makes no difference where the focus is, indeed, without
any clicks, it will abruptly switch from scrolling the page to scrolling one of
the items, to not scrolling anything.  I have indicated Reproducibility = Every
time, however, as the behavior seems to be somewhat random, it really isn't
consistently reproducible at all.  Rather, the inconsistency is reproducible :-|
 (At least, on Windows...)

Reproducible: Always
Steps to Reproduce:
1. Load a page with a form on it.
2. Click anywhere on the page.
3. Use the mouse wheel to scroll.

Actual Results:  See that the window and various scrollable items on the page
will move spasmodically.

Expected Results:  One would expect that the item which was clicked on would
scroll to the end, or top, of its list, and then stop.  If no item has focus,
then the page should scroll.

Logitech Mouse Driver version: 9.24

Other wheel-mouse drivers seem to do the same thing.

Comment 1

16 years ago













*** This bug has been marked as a duplicate of 33732 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.