CSS 2 list-style-type: markers in ordered lists are cut off if they are longer than 4 characters

RESOLVED DUPLICATE of bug 15438

Status

()

--
major
RESOLVED DUPLICATE of bug 15438
16 years ago
5 years ago

People

(Reporter: gliu408, Assigned: attinasi)

Tracking

({intl})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
In the en-US win32 20020813 and mac os 20020814 builds:

If the markers for an ordered list contain more than 4 characters (or 2
double-byte characters), the leftmost character(s) will disappear on a win32
build and be cut off on a mac build. 

For example, in the attached test HTML file, under the CJK Ordered List section,
the list marker below "二十" (20) should be "二十一." If you open the file with
a win32 build, the "二" in "二十一" disappears. If you open it with a mac build,
you can only see part of the "二." 
Under the Roman Ordered List section, the X in XVIII is missing. 

I have attached the test html file as well as mac and pc screenshots.
(Reporter)

Comment 1

16 years ago
Created attachment 95493 [details]
test html file
(Reporter)

Comment 2

16 years ago
Created attachment 95494 [details]
win32 screenshot of chinese markers
Over to layout.
Assignee: jst → attinasi
Component: DOM Style → Layout
QA Contact: ian → petersen
(Reporter)

Comment 4

16 years ago
Created attachment 95495 [details]
win32 screenshot of roman markers
(Reporter)

Comment 5

16 years ago
Created attachment 95496 [details]
mac os screenshot of chinese markers
(Reporter)

Comment 6

16 years ago
Created attachment 95497 [details]
mac os screenshot of roman markers

Updated

16 years ago
Keywords: intl
(Reporter)

Comment 7

16 years ago
oops, I forgot to change my encoding. Here's how the original sentences should look:

For example, in the attached test HTML file, under the CJK Ordered List section,
the list marker below "¶þÊ®" (20) should be "¶þʮһ." If you open the file with
a win32 build, the "¶þ" in "¶þʮһ" disappears. If you open it with a mac build,
you can only see part of the "¶þ." 
Whiteboard: DUPEME

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 15438 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: petersen → amar

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.