Closed Bug 1629748 Opened 3 years ago Closed 3 years ago

Tabs are not enumerated fully

Categories

(Firefox for Android Graveyard :: Android Sync, defect)

Firefox 68
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1408823

People

(Reporter: oluoluolu+ffbugzilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

I use OneTab and FireFox Sync to keep track of my tabs.

Actual results:

Neither shows all the tabs I have on my Android device. In the case of OneTab, that means loss of information with no option to reopen closed tabs.

Expected results:

All tabs should show up in both OneTab and Firefox sync.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Android Sync

How many tabs do you have? We do have a limit (which depends on the length of each URL) but you should be able to get around 100.

(also, see bug 1408823 - I think if you exceed this limit then Fennec will just silently fail to send any tabs, whereas desktop will limit the number it sends to make sure some come through)

(In reply to Mark Hammond [:markh] [:mhammond] from comment #2)

How many tabs do you have? We do have a limit (which depends on the length of each URL) but you should be able to get around 100.

It was about 85. Should/Is there be a limit to how many tabs I can have?

(In reply to Mark Hammond [:markh] [:mhammond] from comment #3)

(also, see bug 1408823 - I think if you exceed this limit then Fennec will just silently fail to send any tabs, whereas desktop will limit the number it sends to make sure some come through)

What is Fennec?

Flags: needinfo?(gkruglov)

That sounds about right—the limit is on the size of the synced payload, to reduce the strain (and storage requirements) on the Sync server. There's a bit of overhead for each tab, including the current URL, back/forward history stack—the last five pages you opened in that tab, including the current one—and icon URL, so 85 is in the ballpark.

Fennec is our nickname for Firefox for Android. Our new Android browser, Firefox Preview, does have logic to limit the number of tabs it uploads...so you still won't see all of them, but it won't fail the whole tab sync.

Flags: needinfo?(gkruglov)

Regarding both OneTab and FireFox Sync, especially the tab behavior exhibited:

I believe the same behavior is triggered as both problems have to do with the tab implementation. So I see similar behavior in Sync (maybe not the backend tho, which is what I think you are asking), and in the extension. Maybe the solution is to have a new API that enumerates all tabs, regardless of whatever is stopping it now.

https://support.mozilla.org/en-US/questions/1284432#answer-1305802

The problem for Android Sync is not that it can't get all the tabs, but there are limits on how much data can be stored on the server, and your number of tabs is over that limit. We are never going to have unlimited space, so there will always be some limit. The solution is to have less tabs open.

I can't comment on OneTab, other than to say that I wouldn't be surprised if it too has some limit, which you might be exceeding.

I'm going to close this as a dupe of bug 1408823 where this problem is being tracked.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1408823
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.