Cannot manipulate images that are associated with client-side image map

VERIFIED DUPLICATE of bug 33583

Status

()

Core
Image Blocking
VERIFIED DUPLICATE of bug 33583
16 years ago
15 years ago

People

(Reporter: Peter Janes, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
The context menu items relating to images ("View Image", "Block Images from this
Server", "Copy Image Location") do not appear over the parts of an image tag
covered by a client-side image map <area>.  In the sample page, the items will
not appear on the left half of the first image, but will on the right; this is a
contrived example, as it's been my experience that most imagemaps cover the
entire image.  The second image shows that images with "ismap" (i.e. a
server-side image map) do not have the same problem.

The relevant code from the sample follows (presuming a 100x100 image):

<map name="test">
<area shape="rect" coords="0,0,50,100" href="/">
</map>
<img src="test-image" usemap="#test">

This behaviour is independent of standards or quirks modes (the sample uses
quirks for simplicity).

*** This bug has been marked as a duplicate of 33583 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.