Closed Bug 1629832 Opened 3 months ago Closed 3 months ago

The titlebar-button buttons don't have a tooltip or accessible label

Categories

(Firefox :: Toolbars and Customization, defect, P1)

x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 77
Tracking Status
firefox-esr68 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- verified

People

(Reporter: MarcoZ, Assigned: Gijs)

References

Details

(Keywords: access, Whiteboard: [access-p2])

Attachments

(1 file, 1 obsolete file)

The Minimize, Maximize/Restore, and Close buttons in the tabs toolbar, outside the tab list, have no accessibility label. These toolbar-buttons probably need tooltip text, or if that isn't wanted, aria-labels.

STR:

  1. On Windows, inspect the buttons with a class of titlebar-button with accessibility inspector.
    • Expected: These should have names.
    • Actual: Names are empty/null.

Setting an access-p2 because these functions are also available via the Alt+Space System window menu.

Component: Tabbed Browser → Toolbars and Customization

I'm a little confused. The alt-space menu doesn't depend on these buttons and is provided by Windows, AIUI. Do you see missing labels there?

The native titlebar buttons are also used everywhere except in fullscreen mode. When are you seeing this issue? Just in fullscreen mode? The buttons should be hidden (also from AT) otherwise.

Flags: needinfo?(mzehe)

Hm, I always see them, regardless of whether I am in full-screen mode or not. They are siblings of the element with ID "tabbrowser-tabs". I can get to them with NVDA object navigation mode, and also when touching the top right of my touch screen.

Flags: needinfo?(mzehe)

(In reply to Marco Zehe (:MarcoZ) from comment #2)

Hm, I always see them, regardless of whether I am in full-screen mode or not. They are siblings of the element with ID "tabbrowser-tabs". I can get to them with NVDA object navigation mode, and also when touching the top right of my touch screen.

Oh right, sorry. I was confused. Wrong buttons. Per discussion with Marco, this is about the buttons at https://searchfox.org/mozilla-central/source/browser/base/content/titlebar-items.inc.xhtml , which we use at least on win10, and the alt-space menu is unaffected.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Type: task → defect
Priority: -- → P1
Summary: The titlebar-button buttons don't have an accessibility label → The titlebar-button buttons don't have a tooltip or accessible label

I've confirmed that the native buttons on win7 do have tooltips. I don't have win8 to hand but I believe the same thing happens there (ie we do not end up showing our own buttons, we show the native ones).

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f36c4ee4bfcc
add tooltips to all the window control buttons, r=dao,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77

Fixed on latest Nightly.

Gijs, should we care about the window control tooltips' color being white, while for normal windows (on Windows 10 at least) it is yellow-ish? (asking to know if it's worth filing a bug about that)

Status: RESOLVED → VERIFIED

needinfo for comment 8

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Itiel from comment #8)

Fixed on latest Nightly.

Gijs, should we care about the window control tooltips' color being white, while for normal windows (on Windows 10 at least) it is yellow-ish? (asking to know if it's worth filing a bug about that)

You can definitely file a bug. I don't know how easy it is to fix (e.g. if this is OS theme dependent and if so, if the OS exposes the relevant theme information in a sane way... historically Windows is a mixed bag in this respect.)

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(itiel_yn8)

Filed as bug 1631411.

Flags: needinfo?(itiel_yn8)
See Also: → 1631411
Blocks: 1631430

Comment on attachment 9141720 [details]
Bug 1629832 - Update the restore window control button label from "Restore" to "Restore Down" as used by Windows r?gijs

Revision D71572 was moved to bug 1631430. Setting attachment 9141720 [details] to obsolete.

Attachment #9141720 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.