Closed Bug 1629848 Opened 4 years ago Closed 4 years ago

loginWithOrigin telemetry does not display the correct number for filtered fields based on similar usernames

Categories

(Toolkit :: Password Manager, defect)

Desktop
All
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox75 --- disabled
firefox76 --- wontfix
firefox77 --- wontfix

People

(Reporter: tbabos, Unassigned)

References

(Blocks 1 open bug)

Details

Affected Versions:
Nightly 77.0a1 (2020-04-14) (64-bit)
Beta 76.0b4

Affected Platforms:
Windows 10
MacOS 10.14
Ubuntu 18.04

Steps to reproduce:

  1. Go to facebook (or any other site)
  2. Save 2 similar credentials, such as: Ana, Anabelle
  3. Reload the Login form and type in "Anab" in the username field

Expected Results:
Autocomplete dropdown:

  • only Anabelle should be displayed in the dropdown since Ana will get filtered out. So we have 1 username displayed + View Saved Logins footer.

Telemetry events:

  • {"acFieldName": "", "hadPrevious": "1", "typeWasPassword": "0", "fieldType": "email", "stringLength": "1", "loginWithOrigin": "1", "loginsFooter": "1"}
    

Actual Results:
loginWithOrigin: 2

  • {"acFieldName": "", "hadPrevious": "1", "typeWasPassword": "0", "fieldType": "email", "stringLength": "1", "loginWithOrigin": "2", "loginsFooter": "1"}
    

Regression-Range:
Not sure if its a regression or it was like this since telemetry was introduced, will look into it.

(In reply to Timea Cernea [:tbabos] from comment #0)

  1. Save 2 similar credentials, such as: Ana, Anabelle

    Expected Results:
    Autocomplete dropdown:
  • only Anabelle should be displayed in the dropdown since Ana will get filtered out. So we have 1 username displayed + View Saved Logins footer.

Telemetry events:

  • {"acFieldName": "", "hadPrevious": "1", "typeWasPassword": "0", "fieldType": "email", "stringLength": "1", "loginWithOrigin": "1", "loginsFooter": "1"}

This is incorrect since stringLength: 1 means that the length of the text in the field is of length 1 but you are talking about when stringLength is 4.

Actual Results:
loginWithOrigin: 2

  • {"acFieldName": "", "hadPrevious": "1", "typeWasPassword": "0", "fieldType": "email", "stringLength": "1", "loginWithOrigin": "2", "loginsFooter": "1"}

For the same reason as above, this is actually correct since the telemetry was recorded when there was only one character typed and therefore both Ana & Anabelle would match. See the user story of the original bug:

  • The event should only be recorded if the length of the text in the field is 0 or 1 (this is simply to reduce volume of telemetry) as 0 and 1 are the most common and expensive cases.

If you type "Anab" faster (or paste it in the field) then we won't even record telemetry for stringLength:1 and that is expected.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.