Closed Bug 1630055 Opened 11 months ago Closed 10 months ago

explaining link for 'allow private windows' goes 'nowhere'

Categories

(Thunderbird :: Add-Ons: General, defect)

defect
Not set
normal

Tracking

(thunderbird76 fixed)

RESOLVED FIXED
Thunderbird 77.0
Tracking Status
thunderbird76 --- fixed

People

(Reporter: buecher, Assigned: Paenglab)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

temporarily load addon. Goto addons page, display details.
The section: execute in private windows has an explaining link: further information, which links to the top of TB help, but not to further information.
link to https://support.mozilla.org/de/products/thunderbird.

Expected results:

preferably, goto correct page, or do not display?

Status: UNCONFIRMED → NEW
Component: Add-Ons: Extensions API → Add-Ons: General
Ever confirmed: true

Resetting severity to default of --.

Richard, could you make the "Run in Private Windows" section of about:addons disappear please? It's on the details page of extensions, not sure if there's any other parts that could also be hidden.

Flags: needinfo?(richard.marti)

I tried to hide the complete private browsing part with

.addon-detail-row-private-browsing,
.addon-detail-row-private-browsing + .addon-detail-row.addon-detail-help-row {
  display: none;
}

but this doesn't work because it seems the aboutAddonsExtra.css isn't loaded. Good visible that the category list on the left has no different background colour to the right part and the help button on the bottom left isn't hidden.

Flags: needinfo?(richard.marti)

Geoff, could the not-loading of the CSS file be also a regression from bug 1525178?

Flags: needinfo?(geoff)

Probably. Take these 5 lines and move them down until they're out of the if (window.location.href == "about:addons") block. Seems to work, although a bunch of the selectors will need changing to match.

Flags: needinfo?(geoff)

Yes, that works. Removed the private browsing section completely.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9142345 - Flags: review?(geoff)
Comment on attachment 9142345 [details] [diff] [review]
1630055-make-aboutAddonsExtra-apply.patch

Review of attachment 9142345 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, but with one nit.

::: mail/base/content/aboutAddonsExtra.css
@@ +25,5 @@
>    margin-bottom: 36px;
>  }
>  
> +/* Hide the help button */
> +.sidebar-footer-item:last-of-type {

This would be better as `.sidebar-footer-item #help-button`.
Attachment #9142345 - Flags: review?(geoff) → review+

#help-button only is enough. :-)

Attachment #9142345 - Attachment is obsolete: true
Attachment #9142642 - Flags: review+
Target Milestone: --- → Thunderbird 77.0
Attachment #9142642 - Flags: approval-comm-beta?

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/fa75d289eeb4
Make the aboutAddonsExtra.css apply again. r=darktrojan DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Comment on attachment 9142642 [details] [diff] [review]
1630055-make-aboutAddonsExtra-apply.patch

approved for beta

[Triage Comment]
Attachment #9142642 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.