Closed Bug 163031 Opened 20 years ago Closed 20 years ago

Marquee tag does not support css correctly

Categories

(Core :: CSS Parsing and Computation, defect, P4)

x86
Windows XP
defect

Tracking

()

VERIFIED FIXED
mozilla1.2alpha

People

(Reporter: bugzilla, Assigned: dbaron)

References

Details

(Keywords: testcase, Whiteboard: [patch])

Attachments

(2 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020813
BuildID:    20020813

The tag Marquee does not suppport some css. For example 
font-family:Verdana;
works, but using other css properties dont work at all.

See testcase.

Reproducible: Always
Steps to Reproduce:
1. Run testcase
2. Css is not applied in a correct way
Attached file Testcase
Attached patch partial fixSplinter Review
This fixes a good bit of it, although 'width' is still broken.
Doron, could you review?
Status: NEW → ASSIGNED
Priority: -- → P4
Whiteboard: [patch]
Target Milestone: --- → mozilla1.2alpha
Comment on attachment 95563 [details] [diff] [review]
partial fix

r=doron
Attachment #95563 - Flags: review+
might consider this for 1.0.1
Keywords: mozilla1.0.1
*** Bug 163401 has been marked as a duplicate of this bug. ***
Comment on attachment 95563 [details] [diff] [review]
partial fix

IE4 seems to treat marquee as an inline, but dbaron tells me that the XBL
implementation of marquee in mozilla uses blocks etc.

I'll sr=kin@netscape.com this patch so that we can style the current
implementation, but if we really want to be compatible with MS we'll need to
make our implementation an inline.

As a testcase, I simply modified attachment 95560 [details] to look something like:

  Before <marquee> ... </marquee> After
Attachment #95563 - Flags: superreview+
according to msdn
(http://msdn.microsoft.com/workshop/author/dhtml/reference/objects/marquee.asp):

This element is a block element.
I'm going to mark this fixed, since it's as fixed as I'm going to make it.  (Fix
checked in, 2002-08-19 11:43 PDT.)

However, I filed two new bugs:
 * bug 163504, to investigate whether it should really be inline-block
 * bug 163505, which would cover fixing the remaining problems with the 'width'
property
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Will this make it to 1.0.1?
verifying based on comments.
The broken width is being looked into in bug 163505
Status: RESOLVED → VERIFIED
Keywords: testcase
You need to log in before you can comment on or make changes to this bug.