Closed Bug 1630371 Opened 1 year ago Closed 1 year ago

Disable DirectComposition when we have a scaled resolution and no hardware stretching.

Categories

(Core :: Graphics: WebRender, defect)

defect

Tracking

()

VERIFIED FIXED
mozilla77
Tracking Status
firefox76 --- verified
firefox77 --- verified

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Details

Attachments

(2 files)

No description provided.
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fce1cf0a2abb
Disable DirectComposition when we have a scaled resolution and no hardware stretching. r=aosmond

Comment on attachment 9141079 [details]
Bug 1630371 - Disable DirectComposition when we have a scaled resolution and no hardware stretching.

Beta/Release Uplift Approval Request

  • User impact if declined: This loosens the condition that we use for disabling DirectComposition. Without this users are missing out on the performance and battery improvements that DirectComposition gives. This is especially important because 76 enables WebRender on some Intel laptops.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Try using Firefox on a machine where DirectComposition was disabled because of lack of HardwareStretching. It should now have DirectComposition.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is just turning on DirectComposition in more situations. The result of the HardwareStretching test is not always what we expected so we ended up disabling DirectComposition on a somewhat random set of users in 75. That served as rough mechanism for gradual rollout. This patch serves to complete that rollout.
  • String changes made/needed:
Attachment #9141079 - Flags: approval-mozilla-beta?
Attachment #9140842 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Attachment #9140842 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77

Comment on attachment 9141079 [details]
Bug 1630371 - Disable DirectComposition when we have a scaled resolution and no hardware stretching.

Needed for Intel WebRender rollout. Approved for 76.0b6.

Attachment #9141079 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

deleted

Flags: needinfo?(jmuizelaar)
Flags: needinfo?(jmuizelaar)
QA Whiteboard: [qa-triaged]

This issue is Verified as fixed in our latest Beta build 76.0b7 and our latest Nightly build 77.0a1 (2020-04-22) on Windows 10.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.