Closed Bug 1630402 Opened 8 months ago Closed 8 months ago

Activating address bar search in bookmarks and history at "about:preferences#privacy" also shows visited sites on click at address bar without typing anything.

Categories

(Firefox :: Address Bar, defect)

75 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1627858

People

(Reporter: d, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

When clicking the new address bar, it shows a list of shortly visited sites, bookmarks and open tabs.

This is a privacy concern, since now at every click at the address bar, part of my history/bookmarks are shown.
This means clients I use my computer in front of at my homeoffice or colleagues (when I bring in my private laptop) might see them too.

Actual results:

When clicking the new address bar, it shows a list of shortly visited sites, bookmarks and open tabs.
One can deactivate search in history, bookmarks and open tabs "about:preferences#privacy", but then neither the list will be shown, and there will there be no search on typing.

Expected results:

Either the results should populate only at typing (as it was before), or there should be an option to disable this separately from the existing options.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Preferences
Component: Preferences → Address Bar
Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1627858
You need to log in before you can comment on or make changes to this bug.