Closed Bug 1630577 Opened 3 years ago Closed 2 years ago

Unable to sign into saturn.de with ETP - Strict enabled

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Unspecified
Android
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: oanaarbuzov, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

Environment:
Browser / Version: Firefox Preview Nightly 200414 (🦎 77.0a1-20200410095419)
Operating System: Huawei P20 Lite (Android 8.0.0) - 1080 x 2280 pixels, 19:9 ratio (~432 ppi density)

Prerequisites:
saturn.de account created.

Steps to Reproduce:

  1. Navigate https://www.saturn.de/webapp/wcs/stores/servlet/LogonForm?redirectURL=https://www.saturn.de/webapp/wcs/stores/servlet/LogonForm?storeId=48352&krypto=sWRJeZ0O2x7z1sBf1ru6DQcmV310vtQaqY8Z4Q6X5X5h4ZoEar0OhWf7mAgjNjtexsRv5062EOrQZL0piBLJNqvr%2FfR2Od4GNWXcw4yJCyS%2FhRGxqea5HmP137xLGNtZ
  2. Dismiss "Cookies" popup.
  3. Type in valid credentials and tap "Anmelden".
  4. Observe behavior.

Expected Behavior:
Login is performed.

Actual Behavior:
Login is not performed.

Note:

  1. With "Standard" protection the login is performed.
  2. Screenshot attached.
Attached image LoginNotPerformed.gif

This only seems to reproduce for me on an actual device, not in the responsive design mode. But since the nightly builds of Firefox Preview effectively cannot be debugged right now until bug 1631012 lands, I'll have to wait for that first.

Severity: -- → S3

The issue no longer occurs, with ETP - Strict login is successfully performed.
https://prnt.sc/z3i1f1

Tested with:
Browser / Version: Firefox Nightly 210210 (🦎 87.0a1-20210209092956)
Operating System: Samsung Galaxy S8 (Android 9) - 1440 x 2960 pixels, 18.5:9 ratio (~570 ppi density)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.