script parameter exchange with flash plugin fails

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Arndt Kritzner, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:0.9.4.1) Gecko/20020508
Netscape6/6.2.3
BuildID:    2002072204

For an intranet groupware application (http://www.intralogic.de) we
use a flash/javascript/php combination to message calendar items to
the users. This works well with IE and Opera, but with Mozilla 1.0 this randomly
(often) produced "Method not implemented"-messages. After reloading the page it
is shown normally.

After update to a more recent mozilla build (2002072204) this error occurs less
often but pushing parameters back to flash works only once. In the following
loops flash variables are not updated with the script results. On server side I
logged the PHP in- and outputs, these are correct. With Netscape 6.2.3 and IE
this mechanism works fine.

The configuration: a flash script activates a php script to read from
the database the next items. If an action becomes active another
window is spawned by a javascript. There a link leads to the calendar.

the details:
-
Flash<>PHP:
loadVariablesNum("PHPscript.php",0,"POST");
-
Flash->Javascript:
getURL("javascript:spawnWindow('PopUp.htm','Erwachet','toolbar=no,...top=100')");
-
Javascript:
<script language="JavaScript1.1"> <!--
function spawnWindow(URL,Name,features){ 
Fenster=window.open(URL,Name,features);
Fenster.focus();
}
//--> </script>
-
PHP output looks like:
alteUhrzeit=2002-07-26+07:53:50&Termin=0&Aktivitaet=2000-08-20+18:09:00&Uhrzeit=2002-07-26+14:33:07&id_person=3



Reproducible: Always
Steps to Reproduce:
see description

Actual Results:  see description

Expected Results:  see description

Comment 1

16 years ago
will need the scriptable flash version to see this working. Arndt, can u pls 
download the latest flash player from macromedia.com and see if this works after 
using it ? Mine is also an older version of flah ( am not sure if scriptable 
version of flash is released for linux or not) Thx!
(Reporter)

Comment 2

16 years ago
No change of the described behavior with the latest flash plugin (2002-07-30).
But the mechanism works in Netscape 6.2.3 not only for windows. It works for
linux too (also with the former used plugin).

Comment 3

16 years ago
reassign
Assignee: beppe → peterl

Comment 4

16 years ago
--->INVALID

Flash is not installed correctly if scripting fails. Make sure you have the
latest Flash 6.0r6x and make sure you have flashplayer.xpt in your plugins
folder. If you do not, you can install it by click ing here:
ftp://ftp.netscape.com/pub/netscape7/english/7.02/windows/win32/eehxkt/flash.xpi
On Linux, be sure you build with gcc 2.x.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.