Closed Bug 1630891 Opened 1 year ago Closed 1 year ago

Add null check for addon's internal Name

Categories

(SeaMonkey :: Build Config, defect)

SeaMonkey 2.53 Branch
defect

Tracking

(seamonkey2.53 fixed, seamonkey2.57esr fixed)

RESOLVED FIXED
Tracking Status
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.2)

Attachments

(1 file)

With the change from checking what a locale addon's internalName was to checking what an its internalName started with, it did not take account of those locale addons that did not have an interalName set.

Attached patch null checkSplinter Review

[Approval Request Comment]
Regression caused by (bug #): 1512882
User impact if declined: if a langpack is installed, can potentially cause problems with other addons
Testing completed (on m-c, etc.): 2.53.3
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Attachment #9141201 - Flags: review?(frgrahl)
Attachment #9141201 - Flags: approval-comm-release?
Attachment #9141201 - Flags: approval-comm-esr60?
Comment on attachment 9141201 [details] [diff] [review]
null check

LGTM r/a+ for our 2.53 and 2.57 release branches.
Attachment #9141201 - Flags: review?(frgrahl)
Attachment #9141201 - Flags: review+
Attachment #9141201 - Flags: approval-comm-release?
Attachment #9141201 - Flags: approval-comm-release+
Attachment #9141201 - Flags: approval-comm-esr60?
Attachment #9141201 - Flags: approval-comm-esr60+
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Whiteboard: SM2.53.2
You need to log in before you can comment on or make changes to this bug.