fast typing in address fields + autocomplete gives messed up focus

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: orion, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
mozilla 1.1b

If i quickly type a pair of names in the address fields,
the first few characters of the second address get chopped and
appended to the end of the first address.

for example, if "scott <scott@blah.com>" and "neal <neal@blah.com>"
are in my address book, and i go to the address field and quickly
(actually at normal typing speed) type "scott<cr>neal<cr>"
i end up with the following addresses:

to: scott <scott@blah.com>n
to: eal@mydomain.com


this is similar to bug 143669,
but is repeatable at any time
in the message-composition process.
(versus just at the begining)
-->varada
Assignee: ducarroz → varada

Comment 2

16 years ago
Ouch. I tried typing "name1", <return>, "name2" in a compose window and just
ended up with "name1name2@domain" in the top one, and a blank new "To:" entry
below it.

Confirming on Windows 2000, build 2002080308 (post 1.1b).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
I confirm this with Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2) Gecko/20021112
(which is the lastest build right now.)

Its really annoying when trying to type emails quickly.
taking all of varada's bugs.
Assignee: varada → sspitzer
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030401]

Confirmed on Win95, and Moz. v1.4a.

I can end up with "N1N2@domain", "N1@domainN2", etc.

Comment 6

16 years ago
*** Bug 158133 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
*** Bug 189397 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
I verified this persists in Mozilla 1.4rc1

Comment 9

15 years ago
*** Bug 225590 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
*** Bug 244515 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Comment 11

13 years ago
This sort of mishmash occurs in webforms and the address bar of Firefox 1.07
(for more than several versions now on Freebsd 5.x and 6.x on AMD64) and also
when typing mail messages in thunderbird 1.0.7.   Seems like a race condition or
something to me.  Wish someone competent would track down the bug, because it
happens every 2 sentences or so on every build of firefox I've used, without fail.

Comment 12

12 years ago
*** Bug 338641 has been marked as a duplicate of this bug. ***
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: esther → composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 15

9 years ago
still occurs
Severity: normal → minor

Updated

9 years ago
Blocks: 140346

Comment 16

4 years ago
I can't reproduce this today. There were some architectural changes to autocomplete since the bug was filed.

Comment 17

3 years ago
Yeah, we should close this
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.