If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Long lists of folders/bookmarks down arrow does not work correctly

VERIFIED FIXED in mozilla1.2beta

Status

SeaMonkey
Bookmarks & History
--
major
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Rainer Bielefeld, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({access, regression})

Trunk
mozilla1.2beta
access, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

801 bytes, patch
Dean Tessman
: review+
jag (Peter Annema)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
Bug 124485 is back again with
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020815
(no problem until build 20020813)

Steps to reproduce:
1. open Bookmarks
2. open bookmark-subfolder with many entries
3. try to scroll down with mouse by "down-arrow"
   expected: list scrolls
   actual: list only scrolls 1 line any mouseclick
(Reporter)

Updated

15 years ago
Keywords: access, regression

Comment 1

15 years ago
seeing a similar thing on Linux; mousing over the down-arrow at bottom of
bookmarks dropdown menu will scroll some lines, then stop. When i mouse over a
bookmark and back to arrow, it scrolls two more lines, then stop.
CVS from today.

Comment 2

15 years ago
can't find any clear dup - resolving as new.
OS/Platform All (guessing it affects more than just Windows and Linux.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All

Comment 3

15 years ago
Sounds like bug 62377.
(Reporter)

Comment 4

15 years ago
Problme still exists in
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020818
It's not only a 1-day-fly
Depends on: 62377

Comment 5

15 years ago
Have noticed this problem since build on 20020810.
The previous build I was using was 20020727 and didn't have any problems
scrolling down in bookmarks.

Scrolling down using keys is ok and scrolling up works as well.

Comment 6

15 years ago
We're still experiencing this bug, using build 1.1b, 2002-08-26, with Linux

Comment 7

15 years ago
This problem still occurs in 20020907.
(Reporter)

Updated

15 years ago
Severity: normal → major
Target Milestone: --- → mozilla1.2alpha

Comment 8

15 years ago
Behavior similar to the bug description seems to also happen on 1.2alpha
release, Linux version. 

Comment 9

15 years ago
The scrolling arrow problem still occurs on 1.2 alpha for windows (Build Id:
2002091014)

Comment 10

15 years ago
This bug also occurs when trying to scroll the main bookmark menu if it is
sufficiently populated, not just sub-folders of the bookmark menu. Confirmed
this on 1.2a (20020914) for Win32 and Solaris.

Comment 11

15 years ago
*** Bug 168134 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
I know what is wrong with this, fix should follow.

Comment 13

15 years ago
Created attachment 99648 [details] [diff] [review]
two line fix for bookmark scrolling bug

This is a two line fix.

The problem is in the code that finds out which index we have scrolled to in a
scrollableView.  The current code uses the bottom right hand corner of each
element, which makes it sensitive to rounding errors.  

The patch switches to using the center of the elements.

Comment 14

15 years ago
Created attachment 99692 [details] [diff] [review]
cvs diff this time

This new patch is made using "cvs diff -u", and should be more usable.

Code changes are the same.  Sorrry about the previous patch, but I am new here.
Attachment #99648 - Attachment is obsolete: true

Comment 15

15 years ago
I can't add the keywords patch and review.

Someone should add the keyword patch, to indicate the patch was written by
someone without check in rights(me).

Someone should add the keyword review, since I believe this patch to be ready
for review.

More important: I am requesting r/sr, and pending that checkin.

Comment 16

15 years ago
*** Bug 168895 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
*** Bug 169098 has been marked as a duplicate of this bug. ***

Comment 18

15 years ago
Adding keywords for adrian.
Keywords: patch, review

Comment 19

15 years ago
I'm not sure, but I believe bug 169607 could be related to this bug. This
problem just recently started happening too.

- Adam

Comment 20

15 years ago
*** Bug 169660 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
*** Bug 169607 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
*** Bug 169791 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
adrian i recommend emailing the people on the reviewers list
http://www.mozilla.org/hacking/reviewers.html to get reviews. Or bugging them on
irc.
Target Milestone: mozilla1.2alpha → mozilla1.2beta

Comment 24

15 years ago
*** Bug 170608 has been marked as a duplicate of this bug. ***

Comment 25

15 years ago
bug is still there

Mozilla 1.2b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020920

Comment 26

15 years ago
adding Bryner to cc list.

Bryner would you review this patch?  You are the person that reviewed the last
few changes to the file.

The patch is small and is explained in comment #13

If you are the wrong person to ask, could you point me to the correct person?
thanks!

Re comment #23:  According linked documents I need peer review before I can ask
for super review via the reviewers list.

Comment 27

15 years ago
Adrian, can you verify the original behavior without this patch, and does this
patch for sure fix it?  I'm having trouble replicating the original problem.

Comment 28

15 years ago
>Adrian, can you verify the original behavior without this patch, and does this
>patch for sure fix it?  

Scrolling of the bookmarks is broken in the latest nightlys, and for months back.

See the eight dupes(there are more sub dupes) and comments #1 #2 #4 #5 #6 #7 #9
#10 #25

Bug 62377 is the same bug and comments 12 13 16 18 19 23 27 29 all report this
problem.  There are two open bugs about this behavior, 12 votes for these bugs.

Yes it is still broken.  Yes this patch fixes it.

>I'm having trouble replicating the original problem.
See comment #1 in this bug and comment #15 in bug 62377 (Phil did a very good
job of describing this problem over there.)

Let me see if I can give directions that you can follow for replicating the bug.
1. launch mozilla
2. click on bookmarks
3. click on manange bookmarks.
4. fill up your bookmarks main menu by clicking on New Separator ~100 times.
(or a submenu, make sure to have a mix of bookmarks and separators)
5. navigate to the menu that you filled up.
6. place your mouse over the down arrow.
7. observe that the bookmark menu begins to scroll down, and then stops.
8. The menus down arrow is now completly broken, clicking or mousing out/in does
nothing.
(you can get it to move down one by highlighting/unhighlighting the lowest
bookmark, but this method of moving works without ever mousing over the down
arrow.  This method is a true pain)

If you still cannot see this bug, try looking at some of the directions in the
dupes.


So how does this patch fix the problem?

The problem is in the code that discovers how many elements have been scrolled
past.  It uses the bottom righthand corner of the each element and sees if we
have scrolled past that corner.  When it detects the corner as being past the
scrolled to point it thinks that we have scrolled to this index in the menu. 
When going down it then scrolls to the index+1 element, however sometimes the
code thinks that we have scrolled to the index-1 element(index-1+1=index)
therefore we scroll nowhere.  

The patch makes the index discovery code calculate the correct index.  It does
this by using the middle of the elements, removing the possiblity of pixel round
offs creating index off by one errors.  No index off by one errors means that we
scroll correctly.

Other solutions:
1. use the top of the elements  
   Rejected: this would break scrolling up.
2. Scroll by twos, so when off by one we still scroll albeit by one or by three.
   Rejected: other users of this code would get buggy scroll results.
   However there are currently no other users of this code, making my patch low 
   risk.
3. Ensure there is never an off by one or rounding of pixel values
   Rejected: impossible.

Comment 29

15 years ago
Comment on attachment 99692 [details] [diff] [review]
cvs diff this time

Thanks for the thorough explanation.

r=me
Attachment #99692 - Flags: review+

Comment 30

15 years ago
*** Bug 171444 has been marked as a duplicate of this bug. ***

Comment 31

15 years ago
*** Bug 171622 has been marked as a duplicate of this bug. ***

Comment 32

15 years ago
*** Bug 171817 has been marked as a duplicate of this bug. ***

Comment 33

15 years ago
*** Bug 171829 has been marked as a duplicate of this bug. ***

Comment 34

15 years ago
*** Bug 171860 has been marked as a duplicate of this bug. ***

Comment 35

15 years ago
removing self from spam list ... err cc list

Comment 36

15 years ago
oops, note to self: click not only e-mail, but checkbox underneath to remove

Comment 37

15 years ago
*** Bug 151892 has been marked as a duplicate of this bug. ***

Comment 38

15 years ago
*** Bug 172168 has been marked as a duplicate of this bug. ***

Comment 39

15 years ago
*** Bug 172441 has been marked as a duplicate of this bug. ***

Comment 40

15 years ago
This bug has r= since nearly one week.

Anybody to sr.

This is a very visible and annoying bug.

Comment 41

15 years ago
*** Bug 172654 has been marked as a duplicate of this bug. ***

Comment 42

15 years ago
*** Bug 172837 has been marked as a duplicate of this bug. ***
adrian: Please write a mail directly to a correct reviewer. CC is not the
correct way.

Comment 44

15 years ago
Matti: I emailed ben, hyatt, and bryner last week for an sr.  Anyone else care
to sr?  blake?  hewitt?

Comment 45

15 years ago
*** Bug 173273 has been marked as a duplicate of this bug. ***

Comment 46

15 years ago
Comment on attachment 99692 [details] [diff] [review]
cvs diff this time

sr=jag
Attachment #99692 - Flags: superreview+

Comment 47

15 years ago
timeless checked this in
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 48

15 years ago
*** Bug 62377 has been marked as a duplicate of this bug. ***

Comment 49

15 years ago
verified using 2002100908 on WinXP.
Status: RESOLVED → VERIFIED

Comment 50

15 years ago
*** Bug 173714 has been marked as a duplicate of this bug. ***

Comment 51

15 years ago
*** Bug 173738 has been marked as a duplicate of this bug. ***

Comment 52

15 years ago
*** Bug 171996 has been marked as a duplicate of this bug. ***

Comment 53

15 years ago
bug  is fixed in

Mozilla 1.2b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021009

thanks

Comment 54

15 years ago
*** Bug 174313 has been marked as a duplicate of this bug. ***

Comment 55

15 years ago
*** Bug 174825 has been marked as a duplicate of this bug. ***

Comment 56

15 years ago
*** Bug 174817 has been marked as a duplicate of this bug. ***

Comment 57

15 years ago
*** Bug 174861 has been marked as a duplicate of this bug. ***

Comment 58

15 years ago
*** Bug 175004 has been marked as a duplicate of this bug. ***

Comment 59

15 years ago
*** Bug 174909 has been marked as a duplicate of this bug. ***

Comment 60

15 years ago
Judging on the amount of dup spam, I'd say a lot of people need to upgrade to
the latest build.

Removing myself, since this bug has been fixed.  Verified WinME 2002101308.

Comment 61

15 years ago
Bug has been fixed in Build 2002101303, so am removing name from list. Thanks to
all you programmers. 

Comment 62

15 years ago
Bug fixed, verified in Win2k Thanks to all you programmers ...  Removing from 
CC list.

Comment 63

15 years ago
*** Bug 174602 has been marked as a duplicate of this bug. ***

Comment 64

15 years ago
*** Bug 176147 has been marked as a duplicate of this bug. ***

Comment 65

15 years ago
Bug seems to be fixed in Mozilla 1.2b (Microsoft Windows Platform),
remove from the mail-list.

Comment 66

15 years ago
*** Bug 176471 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.