Closed Bug 1631238 Opened 9 months ago Closed 9 months ago

|All Address Books > Properties| hangs Address Book Window (TB Daily)

Categories

(MailNews Core :: Address Book, defect)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 77.0

People

(Reporter: thomas8, Assigned: abdallah.khaled.ali.93)

References

(Regression)

Details

(Keywords: hang, regression)

Attachments

(1 file)

STR

  1. in main AB of TB-Daily, right-click on "All Address Books" > Properties

Actual result

  • no properties dialog
  • Address Book Window hangs (no longer responding)

Expected

  • show Properties dialog (as in release)
  • as long as we don't allow renaming "All Address Books" (why?), note that the AB name in the input text box should be preselected and copyable, but not editable.

(regression; seen on Windows 10)

Keywords: hang

Hello,
I took a look at the issue, it is due to the calling of
window.openDialog(
selectedDir.propertiesChromeURI,
"",
"chrome,modal,resizable=no,centerscreen",
{ selectedDirectory: selectedDir }
);

when the All Address Books is selected, the selectedDir.propertiesChromeURI returns void.

if I add get propertiesChromeURI() with the correct link to abAddressBookNameDialog.xhml to the root in the tree's view, it works.

Should I go ahead and make that change ?

(In reply to Abdallah Afify from comment #2)

if I add get propertiesChromeURI() with the correct link to abAddressBookNameDialog.xhml to the root in the tree's view, it works.

Should I go ahead and make that change ?

Flags: needinfo?(geoff)

Yeah, go on. I think that strictly speaking this isn't a hang, it's opening a window with no URL which just confuses everything.

Flags: needinfo?(geoff)
Regressed by: 1614265
Assignee: nobody → abdallah.khaled.ali.93
Status: NEW → ASSIGNED

Hello Geoff,

I submitted a Patch and I put you as a reviewer

Has r+, so looks ready to land --> checkin-needed-tb

Severity: critical → --
Target Milestone: --- → Thunderbird 77.0

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/ffa711650cb1
Route root AB properties to abAddressNameDialog view. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.